Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Reporting Services - Limiting Records Per Page


Reporting Services - Limiting Records Per Page

Author
Message
only4mithunc
only4mithunc
Old Hand
Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)

Group: General Forum Members
Points: 396 Visits: 2803
Hi Peter,

In 2005 I'm able to do this as mentioned earlier, but the problem is with 2008 .

I have followed the steps you have mentioned.

The sorting tab also was showing the same expression = Ceiling(Rownumber(Nothing)/10) ,then I have removed it.

And completed the steps given by you.

But I'm getting an error as below:

"
The Value expression for the tablix ‘Tablix7’ contains an error: [BC30654] 'Return' statement in a Function, Get, or Operator must return a value.
"

Thanks & Regards,
MC
Peter Brinkhaus
Peter Brinkhaus
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1677 Visits: 7074
only4mithunc (12/8/2010)
Hi Peter,

In 2005 I'm able to do this as mentioned earlier, but the problem is with 2008 .

I have followed the steps you have mentioned.

The sorting tab also was showing the same expression = Ceiling(Rownumber(Nothing)/10) ,then I have removed it.

And completed the steps given by you.

But I'm getting an error as below:

"
The Value expression for the tablix ‘Tablix7’ contains an error: [BC30654] 'Return' statement in a Function, Get, or Operator must return a value.
"




I guess you did not remove the sort expression but just cleared the expression value (leaving the '=' behind). On the Sorting tab select the entire row for the sort expression (by clicking the 'Sort by' text) and then click the Delete button.

Peter
only4mithunc
only4mithunc
Old Hand
Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)

Group: General Forum Members
Points: 396 Visits: 2803
Thank you so much Peter,

Yes you are correct I have done it like that, leaving the "=" sign there, now I have deleted the entire row then it worked!!!!

One more small question, now at the left most side of the report I can see that Grouping column, and in each page it will show 1-10 as I have 10 pages. As I don't want to show this column I have selected that column and visibility property is made to false, now it is not showing but when I export to excel, in each page I can see that blank column.

Can we do something (rather than making the column width very very small ? ) so that this blank column wont come in the report out put as well as while exporting to excel?

Thanks & Regards,
MC
Peter Brinkhaus
Peter Brinkhaus
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1677 Visits: 7074
Why not just remove the column? Right click on the column header, select 'Delete Columns', select 'Delete columns only'.

Peter
only4mithunc
only4mithunc
Old Hand
Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)

Group: General Forum Members
Points: 396 Visits: 2803
Thats correct :-)

Thanks Peter, one more question, in the tablix property I have checked the "Repeat row header , Repeat column header " but the Column header is coming only in the firs page...

Should I do the settings some where else.. ?

Thanks & Regards,
MC
Daniel Bowlin
Daniel Bowlin
SSCrazy
SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)

Group: General Forum Members
Points: 2954 Visits: 2629
Right below the main design window pane is a small pane called the grouping pane. On the right side of the grouping pane is a small drop down arrow, click it and choose advanced. This will show all the row groupings in a graphical format. Choose the appropriate row group and then set its property to RepeatOnNewPage.
only4mithunc
only4mithunc
Old Hand
Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)

Group: General Forum Members
Points: 396 Visits: 2803
Thanks Daniel,

When I tried the option you have mentioned it worked, with making "Keep With Group " Option = After

Can I know what is the significance of "Keep With Group" property?

Thanks & Regards,
MC
Daniel Bowlin
Daniel Bowlin
SSCrazy
SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)

Group: General Forum Members
Points: 2954 Visits: 2629
I believe the Keep with group is supposed to keep groups of data together on a page when possible. For example if you had a group that was order information and a detail section with the details of the order such as products and price. Keep with group is supposed to keep the group and the detail together on a page to make reading the report easier.
only4mithunc
only4mithunc
Old Hand
Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)Old Hand (396 reputation)

Group: General Forum Members
Points: 396 Visits: 2803
Thanks Daniel,

Why I asked was , when I make "Keep With Group " = Before/None , the column header was not repeasting to all the pages, it was comming only in the first page, but when I made it "After" , the header was comming in each pages...

Is this is the it works? Or do you think I made some mistakes so where?

Thanks & Regards,
MC
azher.aziz
azher.aziz
Forum Newbie
Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: General Forum Members
Points: 3 Visits: 64
good solution it works
Group on
=Ceiling(RowNumber(nothing)/3)

Set the group page break property
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search