Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


The number of requests for "XXXServer\XXXUser" has exceeded the maximum number allowed for a single...


The number of requests for "XXXServer\XXXUser" has exceeded the maximum number allowed for a single user.

Author
Message
ahmetilhan
ahmetilhan
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 32
I have created a local user on Report Server Computer and the user has the administrative rights.
When i try to connect Report Server (http://xxx.xxx.xxx.xxx/reportserver) with this user's credantials. (ReportServer directory security is set -only- to Basic Authentication. ).
I get the following error.

Reporting Services Error
--------------------------------------------------------------------------------

The number of requests for "XXXServer\XXXUser" has exceeded the maximum number allowed for a single user.
--------------------------------------------------------------------------------
SQL Server Reporting Services

Then i try to login using a different user with administrative rights on the machine, i can logon successfully.
The system is up for a month but this problem occured today?!? What could be the problem?!?
mvee
mvee
SSC Eights!
SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)SSC Eights! (967 reputation)

Group: General Forum Members
Points: 967 Visits: 449
You might want to check to see if you are limiting the number of connections:

In IIS, go to the properties for the web site that hosts the reports - by default - default web site, go to the performance tab - verify web site connections is set to unlimited or that the limited number meets your needs.

Also - you might want to try NOT using Basic Authentication.

Good luck.
-Megan



sreekanthbs
sreekanthbs
Valued Member
Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)

Group: General Forum Members
Points: 54 Visits: 33
Hi,

I am also facing similar problem... i have checked the performance tab as mentioned earlier. But still the issues persists.

Please help!!
Matt Miller (#4)
Matt Miller (#4)
SSCertifiable
SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)SSCertifiable (7.7K reputation)

Group: General Forum Members
Points: 7662 Visits: 18092
There are settings in the rsreportserver.config file that might help with that...BOL mentions looking for this setting:


MaxActiveReqForOneUser
Specifies the maximum number of simultaneous and in-progress connections that a single user can open to the report server. Once the limit is reached, further connection requests from the user are denied. This configuration setting is intended to mitigate a denial of service attack. Valid values are 0 to a maximum integer. The default is 20.

Note that most requests process very quickly so it is unlikely that a single user will have more than 20 open connections at any given time. If users are opening more than 15 process-intensive reports at the same time, you might need to increase this value.

This setting is ignored for report servers that run in SharePoint integrated mode. For more information about server modes, see Deployment Modes for Reporting Services.



----------------------------------------------------------------------------------
Your lack of planning does not constitute an emergency on my part...unless you're my manager...or a director and above...or a really loud-spoken end-user..All right - what was my emergency again?
sreekanthbs
sreekanthbs
Valued Member
Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)Valued Member (54 reputation)

Group: General Forum Members
Points: 54 Visits: 33
Hi, I got the answer for this. Try this, it may work for you also.

When you browse the Report Manager, you're getting the above error message.

To resolve this issue, Do the following,

Search for the key

---- MaxActiveReqForOneUser in RSREPORTSERVER.config file under the ReportServer directory,



And set the value to 400 that would look like this







Save the rsreportserver.config file and restart the IIS





Specifies the maximum number of simultaneous and in-progress connections that a single user can open to Report Manager. Once the limit is reached, further connection requests from the user are denied. This configuration setting is intended to mitigate a denial of service attack.

Valid values are 0 to a maximum integer. 0 indicates no limit on the number of connections. The default is 20.

Note that most requests process very quickly so it is unlikely that a single user will have more than 20 open connections at any given time. If users are opening more than 15 process-intensive reports at the same time, you might need to increase this value.
svbarve
svbarve
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 49
Hi All
i did the same changes recommended here(changed MaxActiveReqForOneUser to 0). it worked for few days now again the same error had occured. Now the things i can see is even Analysis services becomes unavailable.(can't get accessed from management studio too.)The state of the service is abnormal (can't say it is running or stopped).

The server is quite OK around 300 GB free space availabe with 4 GB Ram.
The size of OLAP cube is around 5GB.

Can anybody help me out on this?
Greg Edwards-268690
Greg Edwards-268690
SSC Eights!
SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)SSC Eights! (825 reputation)

Group: General Forum Members
Points: 825 Visits: 8267
review where you set max active requests.
0 ( no limit ) will allow you to possibly overload the server.
Default was 20 - try 40 as suggested
GE
svbarve
svbarve
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 49
Thanks Greg,

The reason behind keeping MaxActiveReqForOneUser=0 is because i have seen connections getting exceeded beyond 105 (from performance monitor)during working hours. May be exceeding more after that.

But still, i will try to set to some minimum may be around 150.
ahmetilhan
ahmetilhan
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 32
MaxActiveReqForOneUser is the solution that worked for me.
Also try not to set this value to '0', if you are not managing your connections. With too many requests server can be overloaded and crash (done that been there).
Singanan Krishnasamy
Singanan Krishnasamy
Grasshopper
Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)

Group: General Forum Members
Points: 18 Visits: 125
found userful, i have encountered this problem today and fixed it based on this thread. thanks a lot
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search