SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


dbcc checkdb part failed in maintenance plan


dbcc checkdb part failed in maintenance plan

Author
Message
KATHLEEN Y ZHANG
KATHLEEN Y ZHANG
SSCrazy
SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)

Group: General Forum Members
Points: 2046 Visits: 584

Hi, not sure if this is an issue with sql 2005 service pack 2 (installed last week). Part of my maintenance plan checks database integrity. The sql shows:

USE [master]
GO
DBCC CHECKDB WITH NO_INFOMSGS
GO
USE [model]
GO
DBCC CHECKDB WITH NO_INFOMSGS
GO
USE [msdb]
GO
DBCC CHECKDB WITH NO_INFOMSGS

This part fails everyday. The error says:

Check Database Integrity

Check Database integrity on Local server connection
Databases: All system databases
Include indexes
Task start: 2007-04-10T05:00:39.
Task end: 2007-04-10T05:00:39.
Failed0) Alter failed for Server 'XYZ'.

It seems to me like its trying to alter database by changing to to single user mode, like it would do if you have repair_rebuild argument there, but the code does not show. Does anyone have any clue?

Thanks,

Kathleen


noeld
noeld
SSC Guru
SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)SSC Guru (50K reputation)

Group: General Forum Members
Points: 50648 Visits: 2052

http://support.microsoft.com/kb/934459




* Noel
KATHLEEN Y ZHANG
KATHLEEN Y ZHANG
SSCrazy
SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)

Group: General Forum Members
Points: 2046 Visits: 584
Thanks much!
Jonas Bergström
Jonas Bergström
SSC Veteran
SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)SSC Veteran (239 reputation)

Group: General Forum Members
Points: 239 Visits: 166
I got a later version than that kb specifies and still have a problem with checkdb and same error.

Microsoft SQL Server 2005 - 9.00.3282.00 (X64) Aug 5 2008 00:48:00 Copyright (c) 1988-2005 Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 5.2 (Build 3790: Service Pack 2)
KATHLEEN Y ZHANG
KATHLEEN Y ZHANG
SSCrazy
SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)SSCrazy (2K reputation)

Group: General Forum Members
Points: 2046 Visits: 584
I have:
Microsoft SQL Server 2005 - 9.00.3233.00 (X64) Mar 6 2008 21:58:47 Copyright (c) 1988-2005 Microsoft Corporation Standard Edition (64-bit) on Windows NT 5.2 (Build 3790: Service Pack 2)

The error cleared out a while ago, I forget when. Might have been after installing the patch Noel specified.
adey11
adey11
SSC Veteran
SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)SSC Veteran (203 reputation)

Group: General Forum Members
Points: 203 Visits: 82
Check the "Automatically set I/O affinity mask for all processors" in your server properties. We had unselected this to reduce processors for licensing, and the maintenance plan failed the following weekend and since. I reselected thsi and the plan started working. Still sounds like a bug Microsoft should fix as a plan shouldn't fail for this reason.
Rick Bailey-440858
Rick Bailey-440858
Old Hand
Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)Old Hand (334 reputation)

Group: General Forum Members
Points: 334 Visits: 348
I had the same problem and checked every conceivable log and even did profiler traces to no avail.
I finally stumbled onto a solution that at least worked for me. It had to do with enabling AWE (Address Windowing Extensions allow 32-bit operating systems to access large amounts of memory. One first has to enable the lock pages in memory option. See links below. Hope this helps.
http://msdn2.microsoft.com/en-US/library/ms190730.aspx
http://msdn.microsoft.com/en-us/library/ms190673%28SQL.90%29.aspx
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search