SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Length of LOB data exceeds maximum 65536


Length of LOB data exceeds maximum 65536

Author
Message
homebrew01
homebrew01
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12814 Visits: 9222

I'm replicating from a SQL 2005 DB to another server running SQL 2000. We were replicating from 2000 to 2000 without problem. Now, when the users enter data, sometimes they get this error.

Length of LOB data (78862) to be replicated exceeds configured maximum 65536

I found reference to the configuration setting max text repl size (B) and it is set to 65536, but that's the same value in 2000 and I never had a problem. Should I just increase the value ?? I'm hesitant to do it without a better understanding.

TIA





noeld
noeld
SSC-Insane
SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)

Group: General Forum Members
Points: 23466 Visits: 2048
yes. you can simply use:

sp_configure 'max text repl size', 2147483647


* Noel
homebrew01
homebrew01
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12814 Visits: 9222

Clarification: We WERE getting the errors in SQL2000 as well, I just hadn't heard about them because of all the other problems we were having with other things.

Are there any implications to choosing a high number ?





noeld
noeld
SSC-Insane
SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)SSC-Insane (23K reputation)

Group: General Forum Members
Points: 23466 Visits: 2048
the implication is that more buffer space is needed to cover for the large values. If you are not short in memory this should not be an issue.

I have this setting on one of my servers and although the activity is not as high as on my big machines I have had no problems with this setting. Most of the time I have been worried about some other "user" failures

Cheers,


* Noel
homebrew01
homebrew01
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12814 Visits: 9222
Thanks for the help !



sssyed_in
sssyed_in
Grasshopper
Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)

Group: General Forum Members
Points: 11 Visits: 0
I am getting the same error while trying to insert data into the varbinary(max) column in my production environment. But I am getting any error in our dev and test machines, though it is not configured for the maximum 2gb value. The thing is this is happening during insert query, not in transactional replication (msdn says the setting is applicable only for transactional replication). Any ideas will be appreciated.

Many thanks,
Syed
Jagadeesh-658121
Jagadeesh-658121
SSChasing Mays
SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)SSChasing Mays (635 reputation)

Group: General Forum Members
Points: 635 Visits: 36
hi
narayana-1031410
narayana-1031410
SSC Rookie
SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)SSC Rookie (25 reputation)

Group: General Forum Members
Points: 25 Visits: 3
Hi,

Length of LOB data (72174) to be replicated exceeds configured maximum 65536.
This error when it will replicate I am unable to replicate. Client getting this error. On what case this error will through

Plz can you reply as early as possible
subsonic-abercrombie
subsonic-abercrombie
SSC-Enthusiastic
SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)SSC-Enthusiastic (112 reputation)

Group: General Forum Members
Points: 112 Visits: 156
I get the following message:
Ad hoc update to system catalogs is not supported.w00t
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search