SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


error 0x80040E21 "Multiple-step OLE DB operation generated errors...."


error 0x80040E21 "Multiple-step OLE DB operation generated errors...."

Author
Message
Jamie-2229
Jamie-2229
Hall of Fame
Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)

Group: General Forum Members
Points: 3796 Visits: 857
Same error here... very odd
OLE DB Source [11]] Error: SSIS Error Code DTS_E_OLEDBERROR.
An OLE DB error has occurred. Error code: 0x80040E21.
An OLE DB record is available.
Source: "Microsoft SQL Server Native Client 11.0"
Hresult: 0x80040E21
Description: "Multiple-step OLE DB operation generated errors.
Check each OLE DB status value, if available. No work was done.".
Will try rebooting the machine, because according to the IDE, no errors occur but obviously during the processing an error does occur but the IDE ignores it. Question is, why does it do that?

In my package, which ran fine in 2008, I take two columns, separate them with a comma and delimit them with a pipe. I place this string into a text file. The best I can figure it that the comma and the pipe together violate some sort of ANSI7 rule and cause unicode to come into play inside the 2012 IDE.

Ideas?

Jamie
kenambrose
kenambrose
SSChasing Mays
SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)

Group: General Forum Members
Points: 649 Visits: 665
One way to be certain that SSIS will process data elements with exactly the data type you want is to make all the explicit conversions yourself from a "type controlled" import.

For example, read all the data in as text from Excel. Then immediately convert each data element explicitly (perhaps to brand new columns) as desired in your data flow. Then you can be sure that all downstream tasks or components you apply to the data flow will use exactly the data types you expect.



Jamie-2229
Jamie-2229
Hall of Fame
Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)Hall of Fame (3.8K reputation)

Group: General Forum Members
Points: 3796 Visits: 857
That's a good idea. Will give it a shot.

Jamie
khemu8290
khemu8290
Valued Member
Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)

Group: General Forum Members
Points: 63 Visits: 100
Hi the below steps might help to solve issue more quickly.

1.Use the OLE DB Destination.
2.Use the "Table or View - fast load " as data access mode.
3.Check “Keep nulls” and “Table lock” property, and keep the other properties unchecked.
4.Map the new converted columns to SQL destination table columns.


Thanks,
Hemanth(CTS)
ashish.shevale
ashish.shevale
Old Hand
Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)Old Hand (358 reputation)

Group: General Forum Members
Points: 358 Visits: 233
this worked for Me but didnt understand what was the problem
Was anyone able to find it to avoid this again

------------------------------------------------------------------------------------

Ashish
devakisahithi
devakisahithi
Grasshopper
Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)Grasshopper (17 reputation)

Group: General Forum Members
Points: 17 Visits: 10
Hi khemu8290,

The Solution has worked great..I stucked with this issue from last so many days. Thanks for the awesome solution.:-)
khemu8290
khemu8290
Valued Member
Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)Valued Member (63 reputation)

Group: General Forum Members
Points: 63 Visits: 100
Welcome Bro Smile
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search