SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


RS SOLUTION - Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)...


RS SOLUTION - Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)

Author
Message
Sanjay Rama Swamy
Sanjay Rama Swamy
SSC Veteran
SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)

Group: General Forum Members
Points: 217 Visits: 63
I had same problem .....if any one help me out .. it's appriciatable
vikasrana2006
vikasrana2006
SSC-Enthusiastic
SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)SSC-Enthusiastic (120 reputation)

Group: General Forum Members
Points: 120 Visits: 360
Thanks for your Tip.
Nick Beagley
Nick Beagley
SSC Eights!
SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)SSC Eights! (827 reputation)

Group: General Forum Members
Points: 827 Visits: 266
Jacob Luebbers (4/15/2008)
@rholt:

It sounds like you may be running into a Kerberos delegation issue. Are your RS server and the source DB server running on different boxes? If so you may not have your RS server setup to correctly delegate the users' credentials to the DB server, so that final "2nd hop" connection is coming through as anonymous. This has been discussed a few times in various threads, the latest I recall was in a linked server context here. aureolin posted a link partway through the thread (http://msdn2.microsoft.com/en-us/library/aa905162(SQL.80).aspx) that gives you the details on correctly configuring your servers.

Regards,

Jacob


Jacob,

Thanks for the link, that solved my problem too. The SSRS service account had a valid SPN was not enabled for delegation itself.

Regards,
Nick



eleffler
eleffler
SSC Rookie
SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)

Group: General Forum Members
Points: 49 Visits: 2
I just ran into this very same problem today on SQL server 2008 and the solution still works!

Thank you for sharing it makes everyone's life a little easier!



Ed Leffler
http://www.lefflerlabs.com
VirenMann
VirenMann
SSC-Enthusiastic
SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)SSC-Enthusiastic (122 reputation)

Group: General Forum Members
Points: 122 Visits: 149
Fantastic!

This saved me lot of pain.

Thanks
titanzcd
titanzcd
Grasshopper
Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)

Group: General Forum Members
Points: 23 Visits: 0
THAT WORKED!!! Marvellous!
rperreta
rperreta
SSC Rookie
SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)SSC Rookie (47 reputation)

Group: General Forum Members
Points: 47 Visits: 0
For Reporting Services try this.

•Goto Reporting Services Configuration (in Start Menu->Programs->Sql Server->Config Tools.
•Click on Execution Account
•Uncheck "Specify an execution account"
el_otro_yo
el_otro_yo
Grasshopper
Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)Grasshopper (13 reputation)

Group: General Forum Members
Points: 13 Visits: 8
Thank you!!!!!!
mcvilbar
mcvilbar
SSC-Addicted
SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)SSC-Addicted (429 reputation)

Group: General Forum Members
Points: 429 Visits: 120
It helped a lot for me... yehey!!!!!!!!:-D
simon.bishop
simon.bishop
Valued Member
Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)

Group: General Forum Members
Points: 51 Visits: 7
Outstanding -- worked like a charm. Thank you very much!
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search