Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


The identifier that starts with....is too long. Maximum length is 128.


The identifier that starts with....is too long. Maximum length is 128.

Author
Message
JM-92548
JM-92548
Valued Member
Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)Valued Member (74 reputation)

Group: General Forum Members
Points: 74 Visits: 2

I have a SP that recieves parameters except that when sending down one parameter I get the following error.

The identifier that starts with....is too long. Maximum length is 128.

I have one parameter that is passing a length of 140.

Is there a way to increase this size pass 128?

Thanks

 





Kenneth Wilhelmsson
Kenneth Wilhelmsson
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1575 Visits: 699

AFAIK, nope.

BOL states the max identifier length as 128 characters. Can't go beyond that.

/Kenneth





sushila
sushila
SSCrazy
SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)

Group: General Forum Members
Points: 2565 Visits: 639
here're some links that could provide you with workarounds....


source 1
source 2
source 3
sql 7.0







**ASCII stupid question, get a stupid ANSI !!!**
Kenneth Wilhelmsson
Kenneth Wilhelmsson
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1575 Visits: 699

Ah, now I understand the problem (duh)

Don't use double quotes around strings, use single quotes. This is the most bulletproof solution, since then it doesn't matter if QUOTED_IDENTIFIER is set to either OFF or ON. Remember, in Transact-SQL, always use single quotes, never double quotes.

If, somehow you can't avoid to use double quotes denoting strings, then you must ensure that for the connection QUOTED_IDENTIFIER is set to OFF. It's a bit more hassle this way, since each connection can override the serversetting - you have to enforce this everywhere in the clientcode making the connection...

/Kenneth





rahim.ali
rahim.ali
Forum Newbie
Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)

Group: General Forum Members
Points: 4 Visits: 15
Single quote should be used when passing String to a query or Stroed Procedure in Transact SQL
msgmahesh
msgmahesh
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 11
Thanks guys! the single quote idea worked for me.
Naomi N
Naomi N
Grasshopper
Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)

Group: General Forum Members
Points: 19 Visits: 232
I am getting the exact same error. I have a huge binary file and I want to pass the binary content (as is) from Visual FoxPro to SQL Server using insert command or update command. I am getting this error. Is there a way to bypass this error?

My SQL command looks like this

insert into Settings (SettingVal) values (cast (long binary string here as varbinary(max)) -- tried using image with the same result.
May be I should try adding single quotes around the varbinary value?
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search