SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL Server 2000 not listening on TCP/IP port 1433


SQL Server 2000 not listening on TCP/IP port 1433

Author
Message
NB-230241
NB-230241
SSC-Enthusiastic
SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)

Group: General Forum Members
Points: 113 Visits: 1
I have SQL Server 2000 running on my laptop at work as part of our development platform. I noticed recently when trying to export a database from another machine that the server on my machine was no listening on port 1433 like it should be. It is only using named pipes from what I can tell. I have set exceptions in my Windows XP firewall that allow both the program (sqlservr.exe) as well as the ports 1433TCP and 1434UDP from anywhere. There are no other firewalls. I have also done a netstat -an to get a listing of open and listening ports and it is not listed among them. If anyone has any ideas I would greatly appreciate the help getting this fixed. Thanks. Below is my error log:

2005-05-03 15:32:29.26 server Microsoft SQL Server 2000 - 8.00.194 (Intel X86)
Aug 6 2000 00:57:48
Copyright (c) 1988-2000 Microsoft Corporation
Personal Edition on Windows NT 5.1 (Build 2600: Service Pack 2)

2005-05-03 15:32:29.28 server Copyright (C) 1988-2000 Microsoft Corporation.
2005-05-03 15:32:29.28 server All rights reserved.
2005-05-03 15:32:29.28 server Server Process ID is 4132.
2005-05-03 15:32:29.28 server Logging SQL Server messages in file 'd:\MSSQL Datafiles\MSSQL\log\ERRORLOG'.
2005-05-03 15:32:29.31 server SQL Server is starting at priority class 'normal'(1 CPU detected).
2005-05-03 15:32:29.81 server SQL Server configured for thread mode processing.
2005-05-03 15:32:29.83 server Using dynamic lock allocation. [500] Lock Blocks, [1000] Lock Owner Blocks.
2005-05-03 15:32:29.88 spid3 Starting up database 'master'.
2005-05-03 15:32:30.11 spid3 0 transactions rolled back in database 'master' (1).
2005-05-03 15:32:30.12 spid3 Recovery is checkpointing database 'master' (1)
2005-05-03 15:32:30.21 server Using 'SSNETLIB.DLL' version '8.0.194'.
2005-05-03 15:32:30.21 spid5 Starting up database 'model'.
2005-05-03 15:32:30.26 server SQL server listening on Shared Memory, Named Pipes.
2005-05-03 15:32:30.26 server SQL Server is ready for client connections
2005-05-03 15:32:30.28 spid3 Server name is 'HM-ISDEV08'.
2005-05-03 15:32:30.28 spid3 Skipping startup of clean database id 5
2005-05-03 15:32:30.28 spid3 Skipping startup of clean database id 6
2005-05-03 15:32:30.28 spid3 Starting up database 'msdb'.
2005-05-03 15:32:30.48 spid5 Clearing tempdb database.
2005-05-03 15:32:31.47 spid5 Starting up database 'tempdb'.
2005-05-03 15:32:31.52 spid3 Recovery complete.
philcart
philcart
SSC-Dedicated
SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)

Group: General Forum Members
Points: 37289 Visits: 1441

A couple of potential problems from the log,

"2005-05-03 15:32:30.26 server SQL server listening on Shared Memory, Named Pipes."

You might need to enable the TCP/IP protocol before SQL will listen on a TCP port

Also, an unrelated issue,

"2005-05-03 15:32:30.28 spid3 Server name is 'HM-ISDEV08'."

It's not exactly wise to have a hyphenated name for the server.



Hope this helps
Phill Carter
--------------------
Colt 45 - the original point and click interface

Australian SQL Server User Groups - My profile
Phills Philosophies
Murrumbeena Cricket Club
sivaprasad
sivaprasad
SSCertifiable
SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)SSCertifiable (5.4K reputation)

Group: General Forum Members
Points: 5433 Visits: 269

Please Check on Start -->> All Programs-->>Microsoft SQL Server--> Server Network Utility, Where TCP/IP appears on enabled protocols.

Otherwise add it.

Hope this helps..



Sivaprasad S - [ SIVA ]http://sivasql.blogspot.com/
Nicholas Cain
Nicholas Cain
One Orange Chip
One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)One Orange Chip (27K reputation)

Group: General Forum Members
Points: 27707 Visits: 6203
You might want to check out http://support.microsoft.com/kb/841251/ with regards Windows XP and firewall problems.



Shamless self promotion - read my blog http://sirsql.net
NB-230241
NB-230241
SSC-Enthusiastic
SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)

Group: General Forum Members
Points: 113 Visits: 1
Thanks for the help all but none of those are the problem. You all should have been tipped off to TCP/IP being installed with the line:

2005-05-03 15:32:30.21 server Using 'SSNETLIB.DLL' version '8.0.194'.

Which is what TCP/IP uses as well as multiprotocol. Also, I mentioned I completely opened the firewall for SQL Server 2000, the executable as well as the ports 1433TCP and 1434 UDP.

I still have not figured out what was going on but as a last effort for the day I installed SP3a for SQL Server 2000 and it fixed the problem. The server is now showing up on ports 1433TCP and 1434UDP. Good luck to you all and I hope this helps answer the problem for others looking for the same answer.
philcart
philcart
SSC-Dedicated
SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)SSC-Dedicated (37K reputation)

Group: General Forum Members
Points: 37289 Visits: 1441

Ok, so it's using the SSNETLIB.DLL, but as shown by this line

"2005-05-03 15:32:30.26 server SQL server listening on Shared Memory, Named Pipes."

The server is NOT listening on TCP so therefore it doesn't matter what DLL it loads. If it was, you would see a message alongs the lines of,

SQL server listening on TCP, Shared Memory, Named Pipes.

As mentioned by sivaprasad, check the Server Network Utility. Make sure TCP/IP is enabled, if it's already enabled, disable it, reboot the server and re-enable it.



Hope this helps
Phill Carter
--------------------
Colt 45 - the original point and click interface

Australian SQL Server User Groups - My profile
Phills Philosophies
Murrumbeena Cricket Club
NB-230241
NB-230241
SSC-Enthusiastic
SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)SSC-Enthusiastic (113 reputation)

Group: General Forum Members
Points: 113 Visits: 1
You're right, it was SUPPOSED to be listening using TCP/IP but it wasn't even though it loaded the dll, hence my original problem. I tried everything I could come up with, including removing it restarting and adding it and restarting. Nothing at all worked. The only thing that I could find or do that did anything to change it was to install the service pack. My guess was a bad dll or something. I really don't know for sure. MS has a dirth of info on it, though I didn't explicitly look at what SP3a fixed, I only looked at what SP4beta fixed(which isn't out yet).
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search