SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL 2014 Clustered with CSV


SQL 2014 Clustered with CSV

Author
Message
MStenz
MStenz
Grasshopper
Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)

Group: General Forum Members
Points: 10 Visits: 156
I just built up a test two node clustered environment with Server 2012R2. Everything seems to be functioning, however, the default file paths seem inaccessible within SQL tools. Meaning, if I try to specify the backup location to restore, I get an error that I cannot access the specified path on the server (C:\ClusterStorage\Instance\SQL\...) - then then the file structure is empty after I select OK. If I create a database new, the files get put in the default locations fine as well as when I'm on the server, I can access the files fine via the CSV path.

My thought is, the SQL cluster is not communicating properly with the CSV. In my prod 2008 R2 cluster, the disks are a dependency of the SQL service while in Windows 2012 R2, it is not (since it is using CSV).

I followed http://blogs.msdn.com/b/clustering/archive/2014/05/08/10523860.aspx - which really doesn't differ too much than older versions of Failover Clustering.

Any thoughts?
will.hall
will.hall
Forum Newbie
Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)

Group: General Forum Members
Points: 8 Visits: 183
Ever receive a response to this? I'm stuck trying to get SQL 2014 installed - is giving me

Updating permission setting for folder 'C:\ClusterStorage\someinstance\MSSQL12.MSSQLSERVER\MSSQL\DATA' failed.
The folder permission setting were supposed to be set to
'DTongue(A;OICI;FA;;;BA)(A;OICI;FA;;;SY)(A;OICI;FA;;;CO)(A;OICI;FA;;;S-1-5-80-3880718306-3832830129-1677859214-2598158968-1052248003)'.
MrSQLDBA
MrSQLDBA
Valued Member
Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)Valued Member (55 reputation)

Group: General Forum Members
Points: 55 Visits: 654
I've got this issue as well...tried all the known workarounds from google search...created sub folders within the CSV, changesd ownership of folders, set local security policy for installation user and service account etc.
will.hall
will.hall
Forum Newbie
Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)

Group: General Forum Members
Points: 8 Visits: 183
In my case it ended up being due to security settings. Group policy was overriding what I had set.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search