SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Vulnerability scan report


Vulnerability scan report

Author
Message
muth_51
muth_51
SSCrazy
SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)

Group: General Forum Members
Points: 2581 Visits: 2930
Hi i am looking for some feedback regarding these below concerns. Our servers have SQL server 2008 R2 -SP2 enterprise edition

we received these vulnerabilities when we performaned vulnerability scan.
1. Microsoft Foundation Class Library Remote Code Execution Vulnerability (MS11-025)

-- So based on my read of the Security Bulletin this is likely for the Microsoft Visual C++ Redistributable Package (since we don’t install Visual Studio on the servers)
Does this usually get installed when we install SQL server 2008? can some one clarify and would there be any issues if i remove it from Database server?


2. Microsoft Windows GDI+ Remote Code Execution Vulnerability (MS09-062)
Is this a known vulnerability and do i need to patch the DB servers when i get this?

3.Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)

Is this a SQL server vulnerability? Do i need to patch the server?
Eirikur Eiriksson
Eirikur Eiriksson
SSC-Forever
SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)

Group: General Forum Members
Points: 41208 Visits: 19490
You have to look at which kind of threats these vulnerabilities are! If it is a local one, normally you would have more problems already as the attacker would need to execute code locally on the system.
Cool
muth_51
muth_51
SSCrazy
SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)

Group: General Forum Members
Points: 2581 Visits: 2930
3. Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)
-- This security patch is released on Feb 2012 before of the SQL Server 2008 R2 SP2(june 2012). DO i need to still apply this patch on the server. Does the Service packs include the Security patch releases which are released before to SP?
Eirikur Eiriksson
Eirikur Eiriksson
SSC-Forever
SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)

Group: General Forum Members
Points: 41208 Visits: 19490
muthyala_51 (6/3/2014)
3. Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)
-- This security patch is released on Feb 2012 before of the SQL Server 2008 R2 SP2(june 2012). DO i need to still apply this patch on the server. Does the Service packs include the Security patch releases which are released before to SP?


Recommend that you do if it shows up on the scan, some components may not be up to date.
Cool
muth_51
muth_51
SSCrazy
SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)

Group: General Forum Members
Points: 2581 Visits: 2930
Eirikur Eiriksson (6/3/2014)
muthyala_51 (6/3/2014)
3. Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)
-- This security patch is released on Feb 2012 before of the SQL Server 2008 R2 SP2(june 2012). DO i need to still apply this patch on the server. Does the Service packs include the Security patch releases which are released before to SP?


Recommend that you do if it shows up on the scan, some components may not be up to date.
Cool



But if i go for applying this patch- the bulletin does not have anything for my SQL version. They have updates only for SQL 2008 R2 RTM only. PLease see below link.
https://technet.microsoft.com/en-us/library/security/ms11-049.aspx
Eirikur Eiriksson
Eirikur Eiriksson
SSC-Forever
SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)

Group: General Forum Members
Points: 41208 Visits: 19490
muthyala_51 (6/3/2014)
Eirikur Eiriksson (6/3/2014)
muthyala_51 (6/3/2014)
3. Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)
-- This security patch is released on Feb 2012 before of the SQL Server 2008 R2 SP2(june 2012). DO i need to still apply this patch on the server. Does the Service packs include the Security patch releases which are released before to SP?


Recommend that you do if it shows up on the scan, some components may not be up to date.
Cool



But if i go for applying this patch- the bulletin does not have anything for my SQL version. They have updates only for SQL 2008 R2 RTM only. PLease see below link.
https://technet.microsoft.com/en-us/library/security/ms11-049.aspx


Those are not SQL Server version specific issues, check out this MSDN article
Cool
muth_51
muth_51
SSCrazy
SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)SSCrazy (2.6K reputation)

Group: General Forum Members
Points: 2581 Visits: 2930
Eirikur Eiriksson (6/3/2014)
muthyala_51 (6/3/2014)
Eirikur Eiriksson (6/3/2014)
muthyala_51 (6/3/2014)
3. Microsoft XML Editor Information Disclosure Vulnerability (MS11-049)
-- This security patch is released on Feb 2012 before of the SQL Server 2008 R2 SP2(june 2012). DO i need to still apply this patch on the server. Does the Service packs include the Security patch releases which are released before to SP?


Recommend that you do if it shows up on the scan, some components may not be up to date.
Cool



But if i go for applying this patch- the bulletin does not have anything for my SQL version. They have updates only for SQL 2008 R2 RTM only. PLease see below link.
https://technet.microsoft.com/en-us/library/security/ms11-049.aspx


Those are not SQL Server version specific issues, check out this MSDN article
Cool


I am confused as in the "applies to" section i dont see for SQL server 2008 R2 SP2. WHen you see closely in applies to section i can see for SQL 2005 SP4 and SQL 2008 SP2, SQL 2008 SP1 etc. but not for SQL server 2008 R2 SP2.
Rudyx - the Doctor
Rudyx - the Doctor
SSChampion
SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)

Group: General Forum Members
Points: 11106 Visits: 2503
These are Windows Server vulnerabilities methinks - these and any other MS security hot-fixes should ALWAYS be applied.

Regards
Rudy Komacsar
Senior Database Administrator

"Ave Caesar! - Morituri te salutamus."
Eirikur Eiriksson
Eirikur Eiriksson
SSC-Forever
SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)SSC-Forever (41K reputation)

Group: General Forum Members
Points: 41208 Visits: 19490
Rudyx - the Doctor (6/4/2014)
These are Windows Server vulnerabilities methinks - these and any other MS security hot-fixes should ALWAYS be applied.

It is an OS scope threat, as I said before, not SQL Server version specific!
Cannot assert the scan but if such issues shows up, do fix them.
Cool
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search