Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Intellisense Issue


Intellisense Issue

Author
Message
mike 57299
mike 57299
SSC-Enthusiastic
SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)

Group: General Forum Members
Points: 165 Visits: 507
Let's say I have a table called Customer with a field called cname.

In SQL 2008 R2, if I type "select customer.c" and press "enter", the intellisense will fill in the cname so that is shows "select customer.cname".

In SQL 2012 - the intellisense shows a dropdown with the "cname" in the dropdown. I have to hit the down arrow then enter to get the same action as I got in SQL 2008 R2.

Any ideas on how to get the old functionality back?

Thanks,
Mike
Andrew G
Andrew G
SSCommitted
SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)SSCommitted (2K reputation)

Group: General Forum Members
Points: 1999 Visits: 2226
http://social.msdn.microsoft.com/Forums/sqlserver/en-US/5bff42a4-966c-424f-8e51-67b6e17814d3/has-the-intellisense-behavior-changed-in-ssms-2012?forum=sqltools

Basically says "go to Edit->IntelliSence-> Toggle Completion Mode " however the setting is not permanent, CTRL+ALT+SPACE is the shortcut to change it.
You can also just hit tab instead.
mike 57299
mike 57299
SSC-Enthusiastic
SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)SSC-Enthusiastic (165 reputation)

Group: General Forum Members
Points: 165 Visits: 507
That is exactly what I want. Thanks!

But... How do I keep this setting. It seems to go back each time I open a new query window. Can't find a permanent setting place.

Mike
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search