SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Report Viewer in Web Page, parameters gray out after first one is selected


Report Viewer in Web Page, parameters gray out after first one is selected

Author
Message
Joe Urbanski
Joe Urbanski
Grasshopper
Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)

Group: General Forum Members
Points: 24 Visits: 26
I have a report that has two parameters, the first one selects a District, the second one is the Plat, there can be 20 districts with multiple plats per district. I select the District and then the second drop down is supposed to be populated with the unique plats that belong to the selected District. the query that populates the second dropdown is something like "Select Plat from table where District = @District".

For both of them I do not set a default value.

When I select a District from the first dropdown the "loading" message appears and once it goes away both dropdowns are disabled and I can not proceed.

I had found a post about changing the web.config file for SSRS and adding a key, the location was (depends on your setup)

C:\Program Files\Microsoft SQL Server\MSRS10.UTSQL1\Reporting Services\ReportManager\Web.config

The line that was added in the keys section was
· <add key="aspnet:MaxHttpCollectionKeys" value="2000" />

I stopped and restarted the reporting service and I still have the problem, it works just fine from Reporting Manager though.

I am using net 4.0, Sql server 2008 standard edition and this is hosted in a website (not a website project)

It used to work until just a few weeks ago.

Any ideas or guidance?
Thanks,
Joe
Joe Urbanski
Joe Urbanski
Grasshopper
Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)Grasshopper (24 reputation)

Group: General Forum Members
Points: 24 Visits: 26
Found the fix for this, I had noticed this error message before but thought it was related to the dropdowns

"Message: Sys.ArgumentNullException: Value cannot be null.

Parameter name: panelsCreated[1]"

I finally searched on that error message and ran across several posts saying to put ScriptMode="Release" into the markup, example below, the drop downs work now :-)

<asp:ScriptManager ID="ScriptManager1" runat="server" ScriptMode="Release">
</asp:ScriptManager>
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search