SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Shared data source not working in report once report is deployed


Shared data source not working in report once report is deployed

Author
Message
neilnewton001
neilnewton001
Valued Member
Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)Valued Member (69 reputation)

Group: General Forum Members
Points: 69 Visits: 118
Hi,

Not so new to ssrs but pretty new to setting up logins on sql server to make the report work. I have a report has a shared datasource which points to a relatively new server. I started out setting up with windows authentication, hoping an admin might have set me up correctly. I am an admin for our sql server instances in AD.
In this case my lack of credentials got me an error:
"Cannot create a connection to data source 'xxxxx' (rsErrorOpeningConnection)
Login failed for 'NT Authority\Anonymous LOGON"
I went back into the data source in the development environment and switch to sql authentication, using my sa account for the server. It works in the preview in BIDS.
What happened when I redeployed the data source is that is not overwritten on the server; I can tell this by going to server and clicking on the data source and looking at the xml; my new credentials are not there. I have no way of deleting the datasource so I'm sort of stuck.

Any help would be appreciate.

Thanks,
Fig000
Scott Murray-240410
Scott Murray-240410
SSC Eights!
SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)SSC Eights! (975 reputation)

Group: General Forum Members
Points: 975 Visits: 3142
How are you deploying your report? If you are deploying from BIDS, one of the options under project properties is to overwrite the datasource. You would want to change that property to true.
Steven.Howes
Steven.Howes
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1596 Visits: 2354
if you right click on the project name and go to properties there's an option to "overwrite Datasource", that should let you fix the datasource.

Your other error sounds like it could be a kerberos problem. Have you set any SPNs?.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search