SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Changed SSIS now won't run in a job


Changed SSIS now won't run in a job

Author
Message
Shaira
Shaira
SSC-Enthusiastic
SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)

Group: General Forum Members
Points: 142 Visits: 276
I had a SSIS package running fine for months through a SQL Agent job. Then ... I deleted a task and re-saved to MSDB now the job just hangs and never finishes. I can run the actual package and all runs fine, I can execute the package in SSMS - using the Integration Services connection and it runs fine. I did not change anything in the job itself. Can someone give me some suggestions on how to trouble shoot this? I'm pretty much a beginner and any help would be appreciated!! TIA!
Andrew G
Andrew G
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2487 Visits: 2254
Are there any saved / protected login credentials in the package? The protectionLevel might be set to EncryptSensitiveWithUserKey, which is why it works for you and not the SQL Agent account.
Add some logging to the package and check where it's hanging. Or run a SQL trace and check what's happening during the agent execution.
Shaira
Shaira
SSC-Enthusiastic
SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)SSC-Enthusiastic (142 reputation)

Group: General Forum Members
Points: 142 Visits: 276
Ahh … password!
I initially had a password on the package, however when I made changes to the package I changed the security setting to ServerStorage and saved it to MSDB. The job then stopped working. After your posting I have now gone back and resaved the package with EncryptAllWithPassword and entered the old password but it still will not run through a job (runs fine in bids).
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search