Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSMS very laggy when typing a query


SSMS very laggy when typing a query

Author
Message
hmbmeister
hmbmeister
Grasshopper
Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)

Group: General Forum Members
Points: 11 Visits: 32
This is a strange one. I am typing a query in SQL Server Management Studio. Nothing is executing on the server. I actually get an hourglass as I type the query at which point I am forced to wait up to 10 seconds before I can type again. I may get one word typed before I get another hourglass.

I tried to RDP to the server directly (thinking it may be something on my computer) and the problem happened there as well. I did a task manager and all the processors were maxed out and the memory usage was maxed as well. SSMS was using 100% of the server.

Again, nothing was executing.

Any ideas?
Matan_Yungman
Matan_Yungman
SSC Rookie
SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)

Group: General Forum Members
Points: 29 Visits: 221
Hi,
Is intellisense enabled?
If it is, can you try to disable it and see if the problem persists?
hmbmeister
hmbmeister
Grasshopper
Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)

Group: General Forum Members
Points: 11 Visits: 32
I have disabled intellisense and testing. So far, no lagging. That is a good sign.
Steven Willis
Steven Willis
SSC-Addicted
SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)SSC-Addicted (483 reputation)

Group: General Forum Members
Points: 483 Visits: 1721
Find your \Local Settings\Temp folder and delete any .tmp files you find there. These files don't seem to clean up after themselves and after awhile you get hundreds of them and SSMS bogs down to a crawl. You may not be able to delete all of the files without closing all your local SQL server instances first, but cleaning up these files usually helps greatly.

 
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search