SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL Server doesn't accept remote connections.


SQL Server doesn't accept remote connections.

Author
Message
MDTech.us_MAN
MDTech.us_MAN
SSC Rookie
SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)

Group: General Forum Members
Points: 41 Visits: 26
Hello,

I am trying to use my SQL Server in my Perl application. I am hosting my Perl code on an external hosting server.

When I was developing my code I was running it on a computer on the same network as the server and everything worked fine. But, when I uploaded the code to the hosting service (replacing the local IP with the public IP of the server), it started failing in the part where it connects to the database saying that the server wasn't found.

Maxwell.

P.S. I did forward port 1433 and I even put the server as DMZ Host (which puts that computer in front of the firewall).
MyDoggieJessie
MyDoggieJessie
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12494 Visits: 7444
I would check 2 things:
1) On your SQL Server, have you allowed remote connections to the server?
2) In your linked server set up, did you set the Data Access to true?

______________________________________________________________________________
"Never argue with an idiot; They'll drag you down to their level and beat you with experience" ;-)
Pulivarthi Sasidhar
Pulivarthi Sasidhar
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2474 Visits: 1026
1) Right click on Sql Server in Sql Management Studio (SMS) -> Connections -> Allow remote connections

2) Right click on Sql Server in Sql Management Studio (SMS) -> Security -> Allow remote connections

3) Sql Server Configuration Manager -> Network Configuration -> Protocols -> Enable Shared memory, Named pipes, TCP/IP

Plz check above steps with option Firewall, to allow N/W traffic od SQL Server.
Makarand Mohandas
Makarand Mohandas
Old Hand
Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)Old Hand (399 reputation)

Group: General Forum Members
Points: 399 Visits: 99
@MDTech.us_MAN
I am guessing this is a shared hosting solution. In that you would not have any access to the server configuration.
I would suggest that you get in touch with you service provider and confirm the name of the SQLserver instance. once you have that, the ensure you database connnection config points to the correct server.

Makarand
MDTech.us_MAN
MDTech.us_MAN
SSC Rookie
SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)

Group: General Forum Members
Points: 41 Visits: 26
1 This SQL server is fully hosted by ME. Only the Perl is hosted my some other company.
1.1 I can't use a third-party SQL hosting service because, I need the SQL Job Agent, which lets me schedule jobs. (I am planing to make a notification job that sends out emails).

2 I don't see the Data Access option in Perl. So I can't set it to true.

3 I already set the remote access option a long time ago.

Maxwell.
MyDoggieJessie
MyDoggieJessie
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12494 Visits: 7444

2 I don't see the Data Access option in Perl. So I can't set it to true.

This is an option on the linked server to the Perl Server?

______________________________________________________________________________
"Never argue with an idiot; They'll drag you down to their level and beat you with experience" ;-)
MDTech.us_MAN
MDTech.us_MAN
SSC Rookie
SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)SSC Rookie (41 reputation)

Group: General Forum Members
Points: 41 Visits: 26
Currently, I don't have a linked server. I connect directly to the SQL Server.
Do I need a linked server?

Maxwell.
MyDoggieJessie
MyDoggieJessie
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12494 Visits: 7444
My apologies I believe I misunderstood you from the start
When I was developing my code I was running it on a computer on the same network as the server and everything worked fine. But, when I uploaded the code to the hosting service (replacing the local IP with the public IP of the server), it started failing in the part where it connects to the database saying that the server wasn't found.
You can't get from your hosting service (which is where the Perl application resides) back into your SQL server.

I don't believe the issue is port-forwarding; you're going to need to allow port 1433 (or whatever port you forwarded that to) through the firewall back to your SQL Server. Not sure what firewall you're using or if you even have access to it, but it would be some TCP rule that allows in "*", and is routed to your internal SQL Server IP address and the appropriate port.

______________________________________________________________________________
"Never argue with an idiot; They'll drag you down to their level and beat you with experience" ;-)
MyDoggieJessie
MyDoggieJessie
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12494 Visits: 7444
As a test, on the external hosted Perl server, can you open a telnet session and connect to the internal IP address of the SQL Server?

______________________________________________________________________________
"Never argue with an idiot; They'll drag you down to their level and beat you with experience" ;-)
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search