SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSIS 2008 Connection Error


SSIS 2008 Connection Error

Author
Message
asdsfssd
asdsfssd
Grasshopper
Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)

Group: General Forum Members
Points: 16 Visits: 29
Client: Windows 7
Server: Windows Server R2
SQL: SQL Server 2008

Trying to connect to Integration Services via SSMS2008. I'm getting the following error:
Connect to SSIS Service on machine "{ServerName}" failed: The RPC server is unavailable


I have tried the following (per the following http://www.kodyaz.com/articles/ssis-integration-services-remote-connection-rpc-server-unavailable.aspx)

1) Verified Server is accepting TCP - local port 135 and remote port 135 (added to Inbound Rules)
2) Client Outbound Rules is allowing TCP - local port 135 and remote port 135.
3) Disable client firewall

None of that didn't work.

I have also tried
1) Server - Added Outbound Rules, Programs and Services, Program Files\Microsoft SQL Server\100\DTS\Binn\MSDTSSrvr.exe (SSIS - Test)

This will allow me to connect from the client.

However, issuing
netstat -a -n -o


shows all kinds of ports open. I think this is a security hole - and probably unacceptable to server admins. However if the moment I restrict SSIS - Test rule to ports 135; I'm not able to connect from the client.

Any help is much appreciated.

So
AlexSQLForums
AlexSQLForums
SSCommitted
SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)SSCommitted (1.9K reputation)

Group: General Forum Members
Points: 1908 Visits: 2269
try this http://www.sqlservercentral.com/blogs/robert_davis/2008/08/13/How-do-I-grant-access-permissions-for-SSIS-to-users/

Alex S
asdsfssd
asdsfssd
Grasshopper
Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)

Group: General Forum Members
Points: 16 Visits: 29
Thanks for responding ... checked your link.

My username is in the Administrators group on the server and the client. On both the server and client, the following are verified:
1) On MsDtsServer, Launch and Activation Permission, Administrators group is allowed for Local Launch, Remote Launch, Local Activation, Remote Activation.
2) On MsDtsServer, Access Permission, Administrators group is allowed for Local Access, Remote Access.

3) Added my username to DCOM group on both the client and server.
4) Restarted SSIS service on both client and server.

Error. Message is
Cannot connect to <servername>.
Additional Information: Failed to retrieve data for this request (Microsoft.SqlServer.Management.Sdk.Sfc)
Connect to SSIS Service on machine "<servername>" failed:
The RPC server is unavailable.

Query Shepherd
Query Shepherd
SSC Veteran
SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)SSC Veteran (214 reputation)

Group: General Forum Members
Points: 214 Visits: 454
Have you got a firewall enabled. If yes, the try to allow the Process C:\Program Files\Microsoft SQL Server\100\DTS\Binn\MsDtsSrvr.exe and open TCP Port 135. You could also pretest if you can telnet port 135 on the remote machine.

Greetz
Query Shepherd
asdsfssd
asdsfssd
Grasshopper
Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)

Group: General Forum Members
Points: 16 Visits: 29
Yes, firewall is enabled.
And yes, I have also tried
1) Server - Added Outbound Rules, Programs and Services, Program Files\Microsoft SQL Server\100\DTS\Binn\MSDTSSrvr.exe

This will allow me to connect from the client. However, issuing
netstat -a -n -o

shows all kinds of ports open. I think this might be a security concern - and probably unacceptable to network and server admins.

And the moment I add port 135 to that same Outbound Rule, I cannot connect from my client.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search