SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL connection error 53 ?


SQL connection error 53 ?

Author
Message
SQL Galaxy
SQL Galaxy
SSCoach
SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)

Group: General Forum Members
Points: 15873 Visits: 3517
Hi,

windows 2008 R2 64 bit
SQL 2008 R2 64 bit

I had checked as below, everythings working fine but not able to connect target database into local client machine.

1. SQL services are running at target machine
2. Enable TCP/IP in SQL Server Configuration
3. Windows Firewall services disabled (switched off)
4. Enabled Remote Connection
5. Enabled SQL Server Browser Service

Still facing connection error number 53


rgds
ananda
Vikrant S Patil
Vikrant S Patil
Ten Centuries
Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)

Group: General Forum Members
Points: 1238 Visits: 345
can you post the complete error message?

Are you using a alias for the connection?
Try connecting using IP address suffixed by the port no ( XX.XX.XXX.XX,portno) just on a test basis.

you can also take a look at the discussion from the following URL:

http://social.msdn.microsoft.com/Forums/en-US/csharpgeneral/thread/3ad597a2-2478-4844-92f8-444fe5063802/



Steve Jones
Steve Jones
SSC Guru
SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)

Group: Administrators
Points: 299836 Visits: 20005
We really need the entire error message, as noted above. 53 is generic, but there should be something with it to explain things.

Are you sure that your client is connecting with the correct protocols as well?

Follow me on Twitter: @way0utwest
Forum Etiquette: How to post data/code on a forum to get the best help
My Blog: www.voiceofthedba.com
SQL Galaxy
SQL Galaxy
SSCoach
SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)

Group: General Forum Members
Points: 15873 Visits: 3517
Error code:

A Network-related or instance-specific error occured while establishing a
connection to SQL Server.
The server was not found or was not accessible.Verfy the instance name is correct
and the SQL Server is configured to allow remote connection.
(provider: Named Pipes provider:40-could not open a connection to SQL Server)
(Microsoft SQL Server, Error:53)


Check the SQL Server service account
using NETWORK SERVICE

Telnet services is not running at target machine.
Steve Jones
Steve Jones
SSC Guru
SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)SSC Guru (299K reputation)

Group: Administrators
Points: 299836 Visits: 20005
It looks like you're connecting on named pipes. Usually that isn't enabled. Use TCPIP

Follow me on Twitter: @way0utwest
Forum Etiquette: How to post data/code on a forum to get the best help
My Blog: www.voiceofthedba.com
Vikrant S Patil
Vikrant S Patil
Ten Centuries
Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)

Group: General Forum Members
Points: 1238 Visits: 345
Building up on Steve's suggestion I would like to suggest that you can try using the following to forcefully use TCP/ IP as a protocol:

1) For Default instance, you can use TCP:Hostname to connect to SQL Server.
2) For Named Instance you can use TCP:Hostname\Named instance to connect to SQL Server.

If SQL server is not listening on default port = 1433, you can also add the port no as a suffix if you have not created a alias

For e.g.

1) For Default instance you can use TCP:Hostname,portno to connect to SQL Server.
2) For Named Instance you can use TCP:Hostname\Namedinstance,portno to connect to SQL Server.

In case you want to confirm the portno that SQL Server is listening on you can take a look at the startup section in the SQL Error Log and then look further for the section that follows " Server is listening on"

The information mentioned above is based on the following URL which provides comprehensive information for troubleshooting connectivity issues to SQL Server Database engine.

http://social.technet.microsoft.com/wiki/contents/articles/2102.how-to-troubleshoot-connecting-to-the-sql-server-database-engine.aspx



Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum







































































































































































SQLServerCentral


Search