SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Cannot start Analysis Services on two instances.


Cannot start Analysis Services on two instances.

Author
Message
Duran
Duran
SSChampion
SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)

Group: General Forum Members
Points: 11223 Visits: 1925
Hello,

I hope someone can help, I have noticed that analysis services has stopped on two instance on my server.
For the first instance, I go to configuration manager and try to start the service I get the standard service did not respond in a timely fashion error, if I change the account that runs it from the domain user account to local system it starts up fine, but try changing it back I get the following WMI error: The server threw an exception. [0x80010105], I see this error in google but it always refers to the agent and not analysis services. In the application log, I see the following error...
The service cannot be started: Message-Handling subsystem: The message manager for the defaul locale cannot be found. The locale will be changed to US English. File system error: The following error occurred during a file operation: Access is denied.

But access denited to what? The services had been up and running for a while and nothing on the server has changed.

As on the second instance gives me the following error in the application log...
The file <path>\CryptKey.bin' could nor be opened. Please check the file for permissions or see if other applications locked it.

Then further up...

The service cannot be started: Message-Handling subsystem: The message manager for the defaul locale cannot be found. The locale will be changed to US English. File system error: The following error occurred while opening the file <path>\CryptKey.bin.

I should say the <path> part is me, saving typing not part of the error. And again, if I change the account running the service to local system if all changes and starts fine, but if I try to change it back I get WMI Error: The process terminated unexpectedly [0x8007042b]. If I hit 'apply' a second time I get another WMI Error, except this time it says 'The server threw an exception. [0x80010105].

I just dont understand why this would suddenly happen, AS on the third instance is fine.

Any help or insight would be most appreciated, and thank you for reading. I am running SQL 2008 R2 RTM (will be service packing soon) on Windows 2008 R2 SP1.

Regards,
D.
jerry-621596
jerry-621596
SSCertifiable
SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)SSCertifiable (5.1K reputation)

Group: General Forum Members
Points: 5087 Visits: 651
It sounds as if someone made some changes to permissions on the domain account. One common issue is the domain account password expiring. If this is the case, you will be prompted with an appropriate message when logging into the account directly.

If you need to use a domain account, make sure it is only used for the SSAS and nothing else. The password should be set to never expire and notes should be made to not touch that account unless absolutely necessary.
Duran
Duran
SSChampion
SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)

Group: General Forum Members
Points: 11223 Visits: 1925
Hi Jerry,

Thanks for getting back, but I have everything you mentioned covered already. I am no closer to working out why I have this issue.

Regards,
D.
Duran
Duran
SSChampion
SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)

Group: General Forum Members
Points: 11223 Visits: 1925
Hello,

In the end, I decided to add the domain user account to the admin group for the local machine to see if it is a permissions issue and AS starts, no problem. What I dont understand is that when it was working previously it was not a member of the admin group. So now I need to figure out what exactly it does not have access to when its not part of the admin group. I think it may be a folder level issue.

Regards,
D.
anthony.green
anthony.green
SSC Guru
SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)SSC Guru (96K reputation)

Group: General Forum Members
Points: 96824 Visits: 8690
Out of interest, did you use services.msc or SSCM to change the service accounts?

If services.msc, remove the user from the admin group and use SSCM to change the service account as this should grant the nessesary access to startup the service.



How to post data/code for the best help - Jeff Moden
Need a string splitter, try this - Jeff Moden
How to post performance problems - Gail Shaw
Managing Transaction Logs - Gail Shaw
Troubleshooting SQL Server: A Guide for the Accidental DBA - Jonathan Kehayias and Ted Krueger


Duran
Duran
SSChampion
SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)SSChampion (11K reputation)

Group: General Forum Members
Points: 11223 Visits: 1925
Hello,

Yes, I always use the SSCM. This is what makes the whole thing such as mystery.

Regards,
Paul.
Dan Crowell
Dan Crowell
SSC-Enthusiastic
SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)SSC-Enthusiastic (140 reputation)

Group: General Forum Members
Points: 140 Visits: 61
Duran (5/10/2012)
Hello,

I hope someone can help, I have noticed that analysis services has stopped on two instance on my server.
For the first instance, I go to configuration manager and try to start the service I get the standard service did not respond in a timely fashion error, if I change the account that runs it from the domain user account to local system it starts up fine, but try changing it back I get the following WMI error: The server threw an exception. [0x80010105], I see this error in google but it always refers to the agent and not analysis services. In the application log, I see the following error...
The service cannot be started: Message-Handling subsystem: The message manager for the defaul locale cannot be found. The locale will be changed to US English. File system error: The following error occurred during a file operation: Access is denied.

But access denited to what? The services had been up and running for a while and nothing on the server has changed.

As on the second instance gives me the following error in the application log...
The file <path>\CryptKey.bin' could nor be opened. Please check the file for permissions or see if other applications locked it.

Then further up...

The service cannot be started: Message-Handling subsystem: The message manager for the defaul locale cannot be found. The locale will be changed to US English. File system error: The following error occurred while opening the file <path>\CryptKey.bin.

I should say the <path> part is me, saving typing not part of the error. And again, if I change the account running the service to local system if all changes and starts fine, but if I try to change it back I get WMI Error: The process terminated unexpectedly [0x8007042b]. If I hit 'apply' a second time I get another WMI Error, except this time it says 'The server threw an exception. [0x80010105].

I just dont understand why this would suddenly happen, AS on the third instance is fine.

Any help or insight would be most appreciated, and thank you for reading. I am running SQL 2008 R2 RTM (will be service packing soon) on Windows 2008 R2 SP1.

Regards,
D.

It is a permissions issue. The account that Analysis Services runs on needs "Write" permissions on the Data and Log folders.
sandy.mclean2
sandy.mclean2
Valued Member
Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)Valued Member (61 reputation)

Group: General Forum Members
Points: 61 Visits: 6
Hi everyone,

I'm also experiencing this issue in not being able to start Analysis Services. I installed SQL Server Enterprise with all the Data Tools mid last year; SSAS, SSIS & SSRS. I've only just tried to connect to SSAS and are receiving the below error:

The service cannot be started: Message-handling subsystem: The message manager for the default locale cannot be found. The locale will be changed to US English .....

We have tried changing the Format in the Language Options Locale Settings and the Registry Editor S-1-5-18 to Locale = 00000409, LocaleName = en-US and the sCountry = United States. And restarted.

Its not working. We can't seem to find any other suggestions in solving this issue - or why it has happened. Can anyone shed some light and save our sanity?
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search