SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSMS 2008 R2 There are not enough resources to complete the operation.


SSMS 2008 R2 There are not enough resources to complete the operation.

Author
Message
Express12
Express12
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1576 Visits: 1058
Every time I click open file from SSMS 2008 R2, I receive error msg:

" Microsoft Office There are not enough resources to complete the operation. Save your work, close the programs, and then try again"

I rebooted my machine multiple times. No luck. I am running Windows 7 Prof and SQL Server 2008 R2 Developer Edition.

Thoughts??

BT
Nicholas Cain
Nicholas Cain
Hall of Fame
Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)Hall of Fame (3.3K reputation)

Group: General Forum Members
Points: 3278 Visits: 6200
How much memory are you running on your system? What other programs do you have open?

Could just be as simple as not enough resources.



Shamless self promotion - read my blog http://sirsql.net
Dev
Dev
Hall of Fame
Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)Hall of Fame (3.7K reputation)

Group: General Forum Members
Points: 3692 Visits: 1602
• Stop / disable the services in SQL Server (& others) that you are not currently using. It will minimize the memory utilization.
• Also, provide min & max memory setting in SQL Server configuration.
• Don’t use multiple programs (applications) at once.
• Add more memory, if possible.

For More:
http://technet.microsoft.com/en-us/library/cc917563.aspx
http://msdn.microsoft.com/en-us/library/ms178067.aspx
juergen.krauss
juergen.krauss
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 12
Hi,
I could resolve this issue on my machine (Windows7 plus MSSQL 2008 R2) by deleting

C:\Users\myname\AppData\Local\Microsoft\Microsoft SQL Server\100\Tools\Shell
and
C:\Users\myname\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell

Good Luck,
Juergen
Express12
Express12
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1576 Visits: 1058
thanks for this feedback. Unfortunately, I do not see this path on my laptop:

C:\Users\myname\AppData\Local\Microsoft\Microsoft SQL Server\100\Tools\Shell

I have SQL Server 2008 R2 Developer Edition installed:

-- Management Studio version 10.50.2425.0
-- MDAC version 6.1.7601.17514
-- MSXML versionn 3.0 5.0 6.0
-- IE version 9.0.8112.16421
-- .Net Framework version 2.0.50727.5448
-- OS is Windows 7 Professional (w/ sp1) version 6.1.7601

any idea where the "\Tools\Shell" directory resides in this config? a Search on SHELL rendered no results.

(fyi, when I do get the error, "There are not enough resources to complete the operation...." I simply click IGNORE and it passes thru to my Windows Explorer to present my Directories/Files.. just an annoying error msg)

BT
juergen.krauss
juergen.krauss
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 12
Any button worked for me to continue, but the message box is just too annoying.
In other forums (with other versions of SQL Server) people reported that this issue can get worse ...

I have got exactly the same components and versions as yours.

Please excuse my silly question:
Did you replace the myname string in the path with your windows logon name?

Are you using a domain account? with roaming enabled?
We use domain accounts, but not roaming profiles.

I noticed that when I deleted both folders, after restarting SSMS the Shell folder in the Roaming tree got recreated immediately.
The corresponding folder in the Local tree got recreated only after some time - with the file CmdUI.PRF in it - Windows 7 recognises it as an Outlook preferences file (I suppose that is where "Office" in the caption of the error dialog comes from ...)

I hope my thoughts are helpful.

J
Express12
Express12
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1576 Visits: 1058
yes, I replaced myname w/ my account..

Not sure about the Roaming attribute.. need to check that

BT
marty-690682
marty-690682
Grasshopper
Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)

Group: General Forum Members
Points: 11 Visits: 27
I had the same issue. When the Open File window opened and the error message appeared, I noticed that the Open File window was full window sized instead of the normal smaller window size. I right clicked on the top bar of the open file window and clicked "Restore" which re-set it to a smaller window. That cured the issue with SSMS.
lynneway14
lynneway14
Forum Newbie
Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)

Group: General Forum Members
Points: 9 Visits: 27
Thanks Forum Newbie. This was driving me crazy. By changing the restore to the smaller window worked.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search