SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Count of Models measure - how do I hide it?


Count of Models measure - how do I hide it?

Author
Message
Jonas Bergström
Jonas Bergström
SSC Rookie
SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)SSC Rookie (49 reputation)

Group: General Forum Members
Points: 49 Visits: 166
How do I get rid of the automaticly showing measure in the excel/powerpivot pivottable fieldlist?

"Values"
___Count of Models

My customer doesn't want it there.

Edit: Oh, forgot to mention, it's 2012/Denali CTP3.
Raunak Jhawar
Raunak Jhawar
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1649 Visits: 1944
Very easy. Glad you asked.

Step 1: Right Click the .BIM file and select View Code
Step 2: Ctrl+F to find __Count of Model
Step 3: Comment the entire Command block that defines this measure
Step 4: Save the change made
Step 5: Now open the .BIM file again --> Build -->Deploy

Note: This is a default measure auto created having value as 1

Hope this helps. Feel free to ask anything you wish.

Regards/Raunak
Now a member of Linkedin

Please visit the all new Performance Point Forum
Please visit the all new Data Mining and Business Analytics Forum
Jonas.SQL
Jonas.SQL
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 59
I saw that it is fixed now in RC0. Great! w00t

https://connect.microsoft.com/SQLServer/feedback/details/712481/-count-of-model-in-tabular-model#tabs

Though my "old" models, created in CTP3 doesn't get "cured" just by being edited in SSDT CTP4 or by being deployed to a RC0 instance - it still needs your fix to hide the "___Count of Models"-measuregroup in the excelsheet. How do I comment a row in XML? /**/ or -- or something else?
Raunak Jhawar
Raunak Jhawar
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1649 Visits: 1944
Jonas.SQL (12/12/2011)
I saw that it is fixed now in RC0. Great! w00t

https://connect.microsoft.com/SQLServer/feedback/details/712481/-count-of-model-in-tabular-model#tabs

Though my "old" models, created in CTP3 doesn't get "cured" just by being edited in SSDT CTP4 or by being deployed to a RC0 instance - it still needs your fix to hide the "___Count of Models"-measuregroup in the excelsheet. How do I comment a row in XML? /**/ or -- or something else?


Yes I had riased the issue in MS Connect.
Follow the steps as above and the default measure will not pop up in Excel or SSMS

again, search of <Command> in .BIM code file --> comment the <Command> XML node that defines [__Count of Models] and deploy the solution again.

Regards/Raunak
Now a member of Linkedin

Please visit the all new Performance Point Forum
Please visit the all new Data Mining and Business Analytics Forum
Jonas.SQL
Jonas.SQL
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 59
I tried like this, but it still shows. Maybe excel has some similar default "connector" for this default measure on that side?

<!--
<Command>
<Text>CALCULATE;
CREATE MEMBER CURRENTCUBE.Measures.[__Count of Models] AS 1;
ALTER CUBE CURRENTCUBE UPDATE DIMENSION Measures, Default_Member = [__Count of Models]; </Text>
</Command>
-->
Raunak Jhawar
Raunak Jhawar
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1649 Visits: 1944
Correct...now save the .BIM file
Next close this file
Now open the solution explorer and double clink on Model.BIM file (or your .BIM) file
Build and deploy your project
Observe the change

OR

Click here

Regards/Raunak
Now a member of Linkedin

Please visit the all new Performance Point Forum
Please visit the all new Data Mining and Business Analytics Forum
Jonas.SQL
Jonas.SQL
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 59
Did follow your directives exactly. Next time I doubleclick .bim file it opens correctly. I build and deploy, but now I cannot use the analyze in excel function, it says some security issue has occurred and the data connection is disabled. If I create a new excel sheet, data connection, AS Server, I now have my self-created meaures listed, but still also has the ___Count of Models.

I close the solution edit the .bim file back as it were, save, open in ssdt, build, deploy, and it has reverted to same old - same old, ie analyze-in-excel is working again, still showing ___Count of Models.
Raunak Jhawar
Raunak Jhawar
SSCommitted
SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)SSCommitted (1.6K reputation)

Group: General Forum Members
Points: 1649 Visits: 1944
Ok...let's do it once again

Comment the block-->Save the file in XML edit mode-->Make sure you have atleast one calculated measure defined in the tabular project(else the project will not open in excel)-->now double click the model.bim file-->build and deploy

If you have followed exactly the steps, the measure will not appear in excel and in ssms

Regards/Raunak
Now a member of Linkedin

Please visit the all new Performance Point Forum
Please visit the all new Data Mining and Business Analytics Forum
Jonas.SQL
Jonas.SQL
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 59
Tried it once more and sorry, that doesn't work in my project. Doesn't really matter though. I'm going RC0 with it. Rebuilding the project, model and everything from scratch.

Thank you for your support, but I'll leave it with that.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search