SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Cannot Start SQL Server Agent


Cannot Start SQL Server Agent

Author
Message
Duran
Duran
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1078 Visits: 1728
Hello,

I hope somebody can help me, I cannot start the SQL Agent (SQL 2005 Ent SP3), I try to change the account in SQL Config Manager but it times out, in the event log I get the following message:

Event Type: Error
Event Source: SQLAgent$InstanceName
Event Category: Service Control
Event ID: 103
Date: 15/03/2011
Time: 11:59:22
User: N/A
Computer: ComputerName
Description:
SQLServerAgent could not be started (reason: SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role).

The account also runs the SQL Service, and is part of the local admins group. The account is also a part of the sysadmin role. In SSMS the Agent XPs show as disabled, and if I try to run:

sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'Agent XPs', 1;
GO
RECONFIGURE
GO

I get the following error message:

Configuration option 'show advanced options' changed from 1 to 1. Run the RECONFIGURE statement to install.
Msg 5845, Level 16, State 1, Line 1
Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.
Msg 15123, Level 16, State 1, Procedure sp_configure, Line 51
The configuration option 'Agent XPs' does not exist, or it may be an advanced option.
Msg 5845, Level 16, State 1, Line 1
Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process

The account does have 'lock pages in memory' privilage, should something else also have this privilage for this to work?

I hope I have supplied enough information, but will provide more if needed. What am I missing? Do I need to repair the agent install?

Any help is most appreciated.

Regards,
D.
Grant Fritchey
Grant Fritchey
SSC-Forever
SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)SSC-Forever (40K reputation)

Group: General Forum Members
Points: 40495 Visits: 32665
Sounds like a simple security setting. Go to the SQl Server Configuration Manager and ensure that the SQL Agent service is running with an appropriate login. I'd suggest using an Active Directory login that has appropriate access to the server and file systems. another option is to run it under the same login as the SQL Server service is running under.

----------------------------------------------------
The credit belongs to the man who is actually in the arena, whose face is marred by dust and sweat and blood...
Theodore Roosevelt

The Scary DBA
Author of: SQL Server Query Performance Tuning and SQL Server Execution Plans
Product Evangelist for Red Gate Software
Duran
Duran
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1078 Visits: 1728
Hey, thanks for getting back. I just worked out what was wrong, I added the SQL service account to the 'lock pages in memory' priv and it all worked out.

Thanks again,
Paul.
TheRedneckDBA
TheRedneckDBA
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2524 Visits: 2610
I'm having this same problem. I'm not using AWE, but tried giving the service account the "lock pages is memory" rights just to rule it out as a cause.

It's for sure set to run as a domain account that has both sysadmin rights in SQL server, and local admin rights on the server itself. It's also the same account that is used for running SQL server itself (which starts and runs fine).

I've run this (below), but can't think of anything else to try. Any suggestions?


sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'Agent XPs', 1;
GO
RECONFIGURE
GO

The Redneck DBA
t2sqldba
t2sqldba
Valued Member
Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)Valued Member (51 reputation)

Group: General Forum Members
Points: 51 Visits: 202
After configuring SQL server service account with 'lock pages in memory' permission you have to restart SQL server service.
Than try to restart the SQL agent service it should come up
John Mitchell-245523
John Mitchell-245523
SSChampion
SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)

Group: General Forum Members
Points: 14320 Visits: 15976
Jason

Did you use SQL Server Configuration Manager to set the service account? Please will you post the content of SQLAGENT.OUT.

John

Edit - just realised that this thread is over a year old. Hope Jason has got it sorted out by now!
Duran
Duran
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1078 Visits: 1728
HA! I've done that so many times!!

D.
motidj
motidj
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 1
Hi,

I had the same problem, but a different scenario:
I converted a physical machine to VM, and the number of the CPU wasn't the same:
16 on physical and 8 on the new VM.

I had the same error in the event log, but different source of problem..

and guess what works for me?
The affinity of the CPU in the SQL properties - go to processors, and check mark the automatic CPU and automatic affinity.

than the agent started..

hope it helped someone..

M.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search