-->
SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 

Ed Elliott's Sql Developer Blog

Ed is a Sql developer who has a mixed background in support, as a dba and as a developer working with a number of languages c, c#, vb, go, assembly with a variety of technologies and is currently trying to make the sql developer community a little bit more agile, one build step at a time!

Archives: April 2018

Interesting Azure ARM "Make it So" behaviour

I had a template that deployed a premium managed disk and a virtual machine. I defined the disk like:


{
"comments": "Managed Disk.",
"type": "Microsoft.Compute/disks",
"name": "[variables('diskName')]",
"apiVersion": "2016-04-30-preview",
"location": "[parameters('location')]",
"tags": {
"displayName": "Data Disk 1 - Presented as LUN 0"
},
"properties": {
"accountType": "Premium_LRS",
"creationData": {
"createOption":…

Read more

0 comments, 296 reads

Posted in Ed Elliott's Sql Developer Blog on 5 April 2018

Interesting Azure ARM "Make it So" behaviour

I had a template that deployed a premium managed disk and a virtual machine. I defined the disk like: { "comments": "Managed Disk.", "type": "Microsoft.Compute/disks", "name": "[variables('diskName')]", "apiVersion": "2016-04-30-preview", "location": "[parameters('location')]", "tags": { "displayName": "Data Disk 1 - Presented as LUN 0" }, "properties": { "accountType": "Premium_LRS", "creationData": { "createOption":…

Read more

0 comments, 178 reads

Posted in Ed Elliott's Sql Developer Blog on 5 April 2018

Interesting Azure ARM "Make it So" behaviour

I had a template that deployed a premium managed disk and a virtual machine. I defined the disk like: { "comments": "Managed Disk.", "type": "Microsoft.Compute/disks", "name": "[variables('diskName')]", "apiVersion": "2016-04-30-preview", "location": "[parameters('location')]", "tags": { "displayName": "Data Disk 1 - Presented as LUN 0" }, "properties": { "accountType": "Premium_LRS", "creationData": { "createOption":…

Read more

0 comments, 118 reads

Posted in Ed Elliott's Sql Developer Blog on 5 April 2018

Why didnt my Azure ARM deploy work?

I have been using Octopus to deploy ARM templates for a while now and the default task that comes with Octopus to deploy doesn’t have any debugging information enabled and when you run this powershell: New-AzureRMResourceGroupDeployment If you don’t have debugging information enabled, the output of a failed deployment is…

Read more

0 comments, 113 reads

Posted in Ed Elliott's Sql Developer Blog on 4 April 2018

Why didnt my Azure ARM deploy work?

I have been using Octopus to deploy ARM templates for a while now and the default task that comes with Octopus to deploy doesn’t have any debugging information enabled and when you run this powershell: New-AzureRMResourceGroupDeployment If you don’t have debugging information enabled, the output of a failed deployment is…

Read more

0 comments, 119 reads

Posted in Ed Elliott's Sql Developer Blog on 4 April 2018

Why didn't my Azure ARM deploy work?

I have been using Octopus to deploy ARM templates for a while now and the default task that comes with Octopus to deploy doesn't have any debugging information enabled and when you run this powershell:

New-AzureRMResourceGroupDeployment

If you don't have debugging information enabled, the output of a failed deployment is…

Read more

0 comments, 1,609 reads

Posted in Ed Elliott's Sql Developer Blog on 4 April 2018