http://www.sqlservercentral.com/blogs/brian_kelley/2008/01/28/metasploit-3-1-is-out/

Printed 2014/04/23 06:50AM

Metasploit 3.1 is out

2008/01/28

The new version of Metasploit is out. Included is a GUI interface. It's a complete re-write in Ruby (note to self, learn more about Ruby) whereas the previous version were in Perl.

  The Metasploit Framework site

If you aren't familiar with Metasploit, here's what it does (taken verbatim from the Metasploit site):

The Metasploit Framework consists of tools, libraries, modules, and user interfaces. The basic function of the framework is a module launcher, allowing the user to configure an exploit module and launch it at a target system. If the exploit succeeds, the payload is executed on the target and the user is provided with a shell to interact with the payload.

There are a number of modules and remote exploits, which are updated as new vulnerabilities come out. Obviously, this is a security tool, and like all security tool, you should have written permission before using it in your organization.

 


Copyright © 2002-2014 Simple Talk Publishing. All Rights Reserved. Privacy Policy. Terms of Use. Report Abuse.