Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSMS not connected on query tabs but still connected in object explorer Expand / Collapse
Author
Message
Posted Tuesday, August 31, 2010 7:51 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Friday, August 29, 2014 8:04 AM
Points: 11, Visits: 263
Hello,

I leave SSMS open on my desktop overnight. Every morning when I get in, all of my query tabs show as "not connected"

Is there a setting that controls this ?

Note, it's not a timeout issue on queries and the databases are still connected in object explorer.

Thanks
R
Post #978000
Posted Thursday, June 6, 2013 6:48 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, June 7, 2013 1:14 PM
Points: 2, Visits: 3
I have the same problem in 2008. I never used to but I re-installed it recently and this started happening.

Have you found anything yet?
Post #1460664
Posted Thursday, June 6, 2013 6:57 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Today @ 11:31 AM
Points: 12,901, Visits: 32,136
zip184 (6/6/2013)
I have the same problem in 2008. I never used to but I re-installed it recently and this started happening.

Have you found anything yet?

Maybe the autoclose proeprty is disconnecting you?
I know on all express versions, you have to pay special attention to the autoclose property, which is ON by default in order to conserve resources.

if you are connected to any of the databases with that proerty =true, it might be the issue:
SELECT * FROM sys.databases where is_auto_close_on = 1



Lowell

--There is no spoon, and there's no default ORDER BY in sql server either.
Actually, Common Sense is so rare, it should be considered a Superpower. --my son
Post #1460668
Posted Thursday, June 6, 2013 7:04 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, June 7, 2013 1:14 PM
Points: 2, Visits: 3
When I run: "SELECT * FROM sys.databases where is_auto_close_on = 1" I get no results.

I don't think it's a DB property because other people who connect to it in my office don't have this problem. I didn't before I re-installed my client either.
Post #1460674
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse