Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQLserver 6.5 ( sqlservr.exe ) hogging 90 -100% of cpu Expand / Collapse
Author
Message
Posted Thursday, July 29, 2010 9:20 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, February 24, 2011 7:21 AM
Points: 45, Visits: 102
Hi All,

I know this seems a bit like a dated question but I have a server with a few databases and the main process is taking all of the cpu, ( the sqlservr.exe and thread msvcrt40.dll ) . Is this a known bug or issue with these versions ?
We have a Win2000 box with 2gb of ram

Thank you
Post #960803
Posted Tuesday, August 03, 2010 9:12 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Friday, January 03, 2014 3:52 PM
Points: 6,066, Visits: 5,277
Silly question to start. Is the most recent SP installed for 6.5? If so, move on to the rest of the answer.

There is an option that a lot of people set call priority boost (I think it was called then) that raises the priority of the SQL thread, I have generally had bad experiences with this. Such as when the server gets busy it won't respond to SQL login packets..

Now with that said, this might be normal, SQL 6.5, 7, 2000, 2005, 2008, can and WILL use all resources available to it. This is especially true on a single processor(1 core) box. You should set the max SQL memory to save at least 256MB with 2GB of hard memory. More if you have middleware or other services on the box.

Not sure if I helped or clouded the issue, let me know..

CEWII
Post #962903
Posted Wednesday, August 04, 2010 8:24 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, February 24, 2011 7:21 AM
Points: 45, Visits: 102
Thx for your response ...

For some reason some process was looping and keeping the thread at 100%. After a server reboot all is fine since and we even increased the max sessions.

If I have any questions I will post back
Post #963505
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse