Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQl2k\2k5 64bit Cluster (A/A) registry issue Expand / Collapse
Author
Message
Posted Monday, April 12, 2010 5:28 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Friday, August 8, 2014 7:31 AM
Points: 53, Visits: 562
Hi
I've got a problem adding new nodes to my established sql2k/2k5 active active cluster.
I've added 2 new nodes to the cluster but when I move sql2k to the new node (havent tried 2k5 yet) it fails to start.
The event log seems to indicate it can't write to the sql error log and further checking it seems the registry parameters for MSSQL are wrong (using old Arg0-2 settings)

As this is a 64 bit system I can't use cluster recovery tool which seems to be designed for this situation.

The registry key is Hkey_Local_machine\Software\wow6432node\microsoft\mssqlserver\mssqlserver\parameters\

I'm thinking I should copy over the entire registry from a good node, but I'm thinking that the cluster will overwrite the changes?

Should I use the CLI checkpoint (SQL Server" /removecheck:) ?

Thanks for your thoughts!
Post #901484
Posted Wednesday, May 5, 2010 7:40 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Friday, August 8, 2014 7:31 AM
Points: 53, Visits: 562
okay I copied the registry over and everything is now working normally.
Post #916052
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse