Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

SQL Server stopped after changing startup parameters for mirroring. Expand / Collapse
Author
Message
Posted Monday, May 25, 2009 6:24 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, September 15, 2014 1:13 AM
Points: 1,535, Visits: 2,577
Dear All,

I was trying to implement mirroring in one of my TEST server.
After the configuration I got an error saying
Mirroring is not enabled.......change startup parameters etc....
As per the information got from Google, I did the following.

went to RUN --> Typed sqlservermanager.msc

Right clicked on SQL Server(instancename) service and clicked on properties and Clicked on Advanced tab

In the startup parameters entered ;-T1400 and click on OK
( Removed the following from startup parameters and entered only ;-T1400.
-dC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\master.mdf;
-eC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG;
-lC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\mastlog.ldf
)

Restarted SQLservices.

NOW MY SQL SERVER IS NOT WORKING. I AM NOT ABLE TO START THE SERVICE.It is giving the message,Windows could not start the SQL Server on local computer.For more information, review the System Event Log.If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 3417.

Can anyone help me pls.

Thanks in advance.
Post #722940
Posted Monday, May 25, 2009 6:31 AM
SSCarpal Tunnel

SSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal Tunnel

Group: General Forum Members
Last Login: Thursday, August 7, 2014 2:08 AM
Points: 4,427, Visits: 4,171
This trace flag was only needed when SQL 2005 came out as RTM version which didn't support mirroring.
Once you install SP1 (or higher) you don't need this any more, so I would advise to remove the startup parameter and update you SQL Server instance(s) to SP3.


Markus Bohse
Post #722941
Posted Monday, May 25, 2009 6:34 AM
SSCarpal Tunnel

SSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal Tunnel

Group: General Forum Members
Last Login: Thursday, August 7, 2014 2:08 AM
Points: 4,427, Visits: 4,171
PS. Of course, if you have removed the parameters for the master files and the logfiles you must add them again.

(dC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\master.mdf;
-eC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG;
-lC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\mastlog.ldf
)


Markus Bohse
Post #722944
Posted Monday, May 25, 2009 6:39 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, September 15, 2014 1:13 AM
Points: 1,535, Visits: 2,577
Hi,
Thanks for your quick reply.
I added those parameters back. But still it's nto working.
What should I do now..?
By the way, it's SQL Server 2005 Standared edition
with SP2 installed. Why mirroring was not working then.?

Once again thanks.

Post #722948
Posted Monday, May 25, 2009 7:01 AM
SSCarpal Tunnel

SSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal Tunnel

Group: General Forum Members
Last Login: Thursday, August 7, 2014 2:08 AM
Points: 4,427, Visits: 4,171
As for why SQL still don't start look in the Windows eventlog for the exact error message. You might just have made a typing error.

Why mirroring wasn't working I don't know without you giving us the exact error. You say that you're server is SQL2K5 Std with SP2, but what about the mirroring partner server?


Markus Bohse
Post #722958
Posted Monday, May 25, 2009 7:33 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, September 15, 2014 1:13 AM
Points: 1,535, Visits: 2,577

mmm...Typing mistake can't happen. I had copied and pasted.
Post #722967
Posted Monday, May 25, 2009 7:45 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: General Forum Members
Last Login: Yesterday @ 2:13 PM
Points: 39,866, Visits: 36,208
What are the exact startup parameters that you have now?


Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #722970
Posted Tuesday, May 26, 2009 1:58 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, September 15, 2014 1:13 AM
Points: 1,535, Visits: 2,577
GilaMonster (5/25/2009)
What are the exact startup parameters that you have now?


I was having the following
-dC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\master.mdf;
-eC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG;
-lC:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\mastlog.ldf

Anyways now I uninstalled and reinstalled SQL server 2005.
I added ;-T1400 in both Principal & mirror server start parameters.

By the way, why DBCC TRACEON(1400) is used..?

Thanks.




Post #723068
Posted Tuesday, May 26, 2009 2:13 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: General Forum Members
Last Login: Yesterday @ 2:13 PM
Points: 39,866, Visits: 36,208
San (5/26/2009)
Anyways now I uninstalled and reinstalled SQL server 2005.
I added ;-T1400 in both Principal & mirror server start parameters.

If both are SP1 or higher, take it out. If not, patch both to SP2 or SP3 and then take it out.

By the way, why DBCC TRACEON(1400) is used..?

Because mirroring was unsupported and disabled in RTM and should not be used. After SP1, mirroring was enabled by default and the need for that traceflag fell away



Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #723075
Posted Tuesday, May 26, 2009 3:01 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, September 15, 2014 1:13 AM
Points: 1,535, Visits: 2,577

Both the servers are SQL Server 2005 32bit with SP2.
You mean to say I can remove ";-T1400" from startup parameters.?

I donno why, I was getting error when I was configuring and was getting the msg that I should set this startup param.
And I sould configure successfully after adding this parameter.

I am bit confused. Wot's "RTM " by the way.?
Post #723104
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse