Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Subscription error:Maximum request length exceeded Expand / Collapse
Author
Message
Posted Sunday, May 24, 2009 4:13 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, November 11, 2013 2:21 PM
Points: 12, Visits: 91
I have a saved subscription and when I edit it I get the following error:

Maximum request length exceeded.


I'm not sure what the problem is as I have never seen this error. If I delete the subscription and re-create it with the changes I want it works fine.

Any help is greatly appreciated.

Thanks,

Marc
Post #722794
Posted Tuesday, May 26, 2009 2:16 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Monday, July 28, 2014 8:41 AM
Points: 1,534, Visits: 1,737
Hey

check out the post below.

http://support.softartisans.com/kbview_825.aspx
Post #723079
Posted Wednesday, September 9, 2009 7:47 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, January 17, 2011 8:33 AM
Points: 1, Visits: 72
Seems to be a bug in Reporting Services.
I came across the same error when trying to alter one of the Subscriptions which was on a Shared Schedule in Reporting Services i.e thru website(http://Servername/Reports/Pages/Folder.aspx)
Deleted the Subscription & tried to recreate it so it could use a Custom Schedule & write the file to Windows Fileshare but it gave me the same error. However, was then able to create the subscription from the Management Studio after connecting to Reporting Services.
Try Browsing thru to that Report under Home--> Reports Folder--> Report Name--> Subscriptions.
You should be able to create/modify/delete subscriptions from here i.e even set schedules,parameters etc.

Regards,
Neeraj
Post #784953
Posted Wednesday, September 16, 2009 1:08 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Thursday, February 6, 2014 9:39 AM
Points: 420, Visits: 487
It's a limit in system.web - http://weblogs.asp.net/hosamkamel/archive/2007/09/18/resolving-maximum-request-length-exceeded-exception.aspx

I changed the web.config under the reports and reportserver virtual directories to this to resolve the error:



It turns out that there is another limit at 64MB so any value larger than 65536 won't matter, but I haven't been able to determine where that limit is being set.


Joshua Perry
http://www.usesage.com
Post #789233
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse