Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

database mirroring monitor - remove server or database Expand / Collapse
Author
Message
Posted Thursday, May 14, 2009 8:53 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:33 AM
Points: 1,140, Visits: 963
does anyone know how to remove a database from the database mirroring monitor once you have registered one. It only seems to let you add databases to monitor, but I can't remove one once it is added.
Post #717037
Posted Thursday, May 14, 2009 9:22 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 18, 2014 6:07 AM
Points: 47, Visits: 782
Not sure I understand but I think you're looking for

ALTER DATABASE {db_name} SET PARTNER OFF

This removes the db from mirroring
Post #717069
Posted Thursday, May 14, 2009 9:25 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 18, 2014 6:07 AM
Points: 47, Visits: 782
Read that a bit fast. To unregister the db from the actual monitor just right click it and select "unregister this database" in regards to 2005 database mirroring monitor
Post #717072
Posted Thursday, May 14, 2009 10:07 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:33 AM
Points: 1,140, Visits: 963
well, when I right click a database, it doesn't give the the option to unregister the database. it only gives an option to register a database, manage server instance connections, or refresh. I have explored both of those screens and have not found a way to unregister. Maybe there is a problem with my copy, as the option just doesn't show up in the right click context menu.
Thanks for the replies.
Post #717122
Posted Thursday, May 14, 2009 10:19 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 18, 2014 6:07 AM
Points: 47, Visits: 782
What build level is it running at?
Post #717140
Posted Friday, May 15, 2009 9:44 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:33 AM
Points: 1,140, Visits: 963
well, it does it in both my 2005 (90.0.3042.00) and my 2008 clients(10.0.1600.22)
Post #718051
Posted Friday, May 15, 2009 11:35 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 18, 2014 6:07 AM
Points: 47, Visits: 782
Are you a sysadmin or in the dbm_moniotr role? It is also possible that you have both tools for 2005 and 2008 and maybe the pack for 2000 in 2005. The installation steps and sequential order in which these are installed is touchy. It's possible the sqlmonitor.exe is having issues that you are selecting. Possibly try the sqlmonitor.exe in the 100 and 90 Binn folder and see if you get the same results. You can mannually launch them by opening sqlmonitor.exe-->Go-->database mirroring

I would also search on SP3 or an updates on msdn for any known updates or fixes in 3042 (SP2).
Post #718139
Posted Monday, May 18, 2009 9:06 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:33 AM
Points: 1,140, Visits: 963
I'll give that a try. I tried manually launching both, and still had the same problem. I'll try the latest service packs and see if that helps. Also, I am SA on the boxes I'm trying to monitor.
Post #719158
Posted Monday, May 18, 2009 10:02 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:33 AM
Points: 1,140, Visits: 963
I found the problem. After installing most recent service packs, DMMM still wasn't working properly. I went to manage server instance connections and removed them all and added them back in. This fixed the problem. I had to re-register all my databases, but it's working now.
Post #719209
Posted Wednesday, April 6, 2011 4:54 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, June 30, 2014 2:16 AM
Points: 180, Visits: 527
Yes, SET PARTNER OFF.
Just worked for me also.
Post #1089159
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse