Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Read_Only Database Expand / Collapse
Author
Message
Posted Thursday, April 09, 2009 9:08 PM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Thursday, May 26, 2011 7:31 AM
Points: 75, Visits: 262
Comments posted to this topic are about the item Read_Only Database

I Like CTE
My Blog - Arz Kiya Hai!!
Post #694585
Posted Friday, April 10, 2009 6:09 AM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, September 24, 2012 8:10 AM
Points: 2,042, Visits: 499
I ran this statement against a SQL Server 2000 database and got this message:

Msg 5058, Level 16, State 5, Line 1
Option 'READ_ONLY' cannot be set in database 'MASTER'.

I think the correct answer is E. Anyone else agree with me on this?
Post #694756
Posted Friday, April 10, 2009 6:15 AM


SSC-Insane

SSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-Insane

Group: General Forum Members
Last Login: Thursday, January 16, 2014 12:03 PM
Points: 21,376, Visits: 9,594
I agree, but I only ran this against 2005 instance (no access to 2000).

makes more sens to not have it read only in the first place.

On 2008 it's definitly not possible to make it read only.
Post #694761
Posted Friday, April 10, 2009 6:42 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Thursday, March 31, 2011 1:40 AM
Points: 1,938, Visits: 208
This is what I got when I ran it in 2005...

Msg 5058, Level 16, State 5, Line 1
Option 'READ_ONLY' cannot be set in database 'master'.
Post #694778
Posted Friday, April 10, 2009 7:00 AM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, September 24, 2012 8:10 AM
Points: 2,042, Visits: 499
The original question was asked about 2000, but I tried 2000,2005,2008 and they all gave me the same error. Now the article that was referenced did mention that it could be done on a 2000 master database, but I wonder if one of the service packs changed this functionality this... Still I think the question is invalid.

Cheers,
Brian
Post #694790
Posted Friday, April 10, 2009 8:02 AM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Tuesday, January 14, 2014 8:44 PM
Points: 1,520, Visits: 739
Yes, I tried on Microsoft SQL Server 2000 - 8.00.2039 (Standard Edition) this option is disable on Master database, could be Enterprice edition might be having... question should specify the version and edtion of 2000... else the answer E is right...I want my points.

Thanx
Vinay


Thanx.
Vinay


http://rdbmsexperts.com/Blogs/
http://vinay-thakur.spaces.live.com/
http://twitter.com/ThakurVinay
Post #694839
Posted Friday, April 10, 2009 8:04 AM


SSC-Insane

SSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-Insane

Group: General Forum Members
Last Login: Thursday, January 16, 2014 12:03 PM
Points: 21,376, Visits: 9,594
It's a bit hard to believe that 67% of the people are wrong about this ;).
Post #694843
Posted Friday, April 10, 2009 8:21 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Thursday, April 17, 2014 12:10 PM
Points: 3,766, Visits: 3,584
Even though BOL says it can be done, I tried it on Microsoft SQL Server 2000 - 8.00.2050 Enterprise Edition and it fails there also.

Post #694854
Posted Friday, April 10, 2009 8:39 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Thursday, March 31, 2011 1:40 AM
Points: 1,938, Visits: 208
I suspect that the reason the error message was because the master database was in use, not because it is invalid to set read only on master. Since all the background processes use master how can there be no users to set read only?
Post #694880
Posted Friday, April 10, 2009 8:47 AM


SSC-Insane

SSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-InsaneSSC-Insane

Group: General Forum Members
Last Login: Thursday, January 16, 2014 12:03 PM
Points: 21,376, Visits: 9,594
Maybe using DAC to connect or having the whole server in single user... but then what's the point of setting master to read_only??
Post #694891
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse