Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. Expand / Collapse
Author
Message
Posted Thursday, August 7, 2008 5:56 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 12:26 AM
Points: 2,840, Visits: 3,963
hi,

i have two linked servers..whenever i execute Stored proc on linkedcserver ,it gives error


Msg 18456, Level 14, State 1, Line 1
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.


on both server's sql agent , i have same login with same rights.

If i use sql authentication it runs fine but if i set a job to execute it it gives above error

how to get rid of this ?

please help me


-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #548200
Posted Thursday, August 7, 2008 11:09 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Friday, August 8, 2014 1:35 PM
Points: 3,475, Visits: 580
To run as a job:
Start your Agent on a domain account. Add this account to both SQL Servers with the appropriate rights to the databases before you start Agent on this account. Add this account to Linked Server Logins and test.
Let us know if it helped.
P.S. - the domain account has to have "Passowrd Never Expires" if you want to use this setup for a long time without worries that your Agent would not start when password expires.



Regards,
Yelena Varshal

Post #548505
Posted Friday, August 8, 2008 12:38 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 12:26 AM
Points: 2,840, Visits: 3,963
hi
thanks for the reply.
actually i tried your suggestion but it couldn't work
i will elaborate more about the problem.
first server has sql agent login : DOMAIN\sqlman (sysadmin)
AND
second server has its sql agent login : DOMAIN\sqlman (sysadmin)

Actually on running Stored proc manually it works fine but when i run it in JOB
it gives error :

Executed as user: DOMAIN\SQLMan. Login failed for user 'DOMAIN\bkumar'. [SQLSTATE 28000] (Error 18456).


Here,
DRIVENAME\bkumar is server windows login which has adminstrative rights on both servers


please suggest


-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #548879
Posted Friday, August 8, 2008 12:45 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Monday, June 23, 2014 6:03 AM
Points: 1,154, Visits: 866
just a suggestion to check,

When you created the linked server have to given the permission to NT\WindowsUser ?
Post #548885
Posted Friday, August 8, 2008 12:48 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 12:26 AM
Points: 2,840, Visits: 3,963
Actually no...can you tell me procedure to check it ?



-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #548890
Posted Friday, August 8, 2008 6:46 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, November 19, 2013 2:10 AM
Points: 138, Visits: 236
Can you check it in a way, by creating sql login on the 2nd server, and then map this sql login to the sql agent login on the instance where you scheduled your job?



Tariq
master your setup, master yourself.
http://mssqlsolutions.blogspot.com
Post #549088
Posted Friday, August 8, 2008 7:03 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 12:26 AM
Points: 2,840, Visits: 3,963
hey,

actually i have 2 servers.

i want to schedule a job on server A which will excute a query on linked server (server B)

i m using sql login : DOMAIN\sqlman( sysadmin) on both servers

and sql agent login\service login : DOMAIN\sqlman

and

as far as i know we cant start a job on sql authentication mode....can we ,if yes then tell me which property or seeting i need to enable


-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #549115
Posted Monday, August 11, 2008 9:45 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Friday, August 8, 2014 1:35 PM
Points: 3,475, Visits: 580
On the Security tab of Linked Server properties you have to add your DOMAIN\sqlman login as Local Login and check Impersonate checkbox or add a remote server's valid login name and pw


Regards,
Yelena Varshal

Post #550379
Posted Friday, October 8, 2010 1:04 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, July 16, 2014 9:09 PM
Points: 1, Visits: 125
Create and add a domain account on both the servers and then add the linked server with
"Be made using this security context" using this domain account.
Post #1001541
Posted Monday, August 12, 2013 8:41 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, August 18, 2014 8:32 AM
Points: 71, Visits: 330
Try changing the job owner to sa, or something with very high level permissions. Usually the job will take the owner of who created it.

If the service account you use is not a domain admin, the anonymous login error is usually related to the service account used for sql not being able to register the spn and also not having delegation setup.

The anonymous logon message ("Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON") was resolved by making two changes to the AD environment.
• Allowed the service account to "write public information” to self.
• Allowed Kerberos delegation to any on the service account then stopped the SQL Service and started it again.

Used setspn -L MSSQLSvc/myhost.redmond.microsoft.com:1433 accountname to check for registration. -- example only

After this was successful I checked SQL authentication between servers using

SELECT auth_scheme FROM sys.dm_exec_connections WHERE session_id = @@spid to make sure it said Kerberos.

Post #1483353
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse