Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Cannot generate SSPI context Expand / Collapse
Author
Message
Posted Thursday, July 17, 2008 1:36 PM
Right there with Babe

Right there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with Babe

Group: General Forum Members
Last Login: Thursday, April 17, 2014 1:23 AM
Points: 732, Visits: 853
Hi All,

When I tried to connect my SQL Server Enterprise Manager, it is giving error "Could not connect to SQL Server"
Reason: Cannot generate SSPI context

I am using windows authentication.

but when I tried to connect using Sa it is not giving any error and I can connect to the EM successfully.

Please help me regarding this

Thanks in advance

Raghavender Chavva


Thanks and Regards!!

Raghavender Chavva
Post #536283
Posted Thursday, July 17, 2008 2:06 PM
SSChasing Mays

SSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing Mays

Group: General Forum Members
Last Login: Thursday, January 2, 2014 10:30 AM
Points: 646, Visits: 731
In the "connect to Server" Dialog Box Click on Options and choose "Named Pipes" from Network Protocols.. click connect.
This is using Windows Authen.
Try this


Maninder
www.dbanation.com
Post #536299
Posted Thursday, July 17, 2008 2:22 PM
Right there with Babe

Right there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with Babe

Group: General Forum Members
Last Login: Thursday, April 17, 2014 1:23 AM
Points: 732, Visits: 853
Sorry,

I can't understand you ?

can you please brief it ?

my sql server is named instance which is in my local system only, when I tried to expand the instance the error generated, it is ok till today morning, dont know what happened in between.


Thanks and Regards!!

Raghavender Chavva
Post #536316
Posted Thursday, July 17, 2008 2:51 PM
SSCarpal Tunnel

SSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal Tunnel

Group: General Forum Members
Last Login: Yesterday @ 8:28 AM
Points: 4,388, Visits: 9,508
First thing you need to do is check the SPN record for that instance of SQL Server. If you do not have access to this, talk to the network folks and have them find the offending SPN record.

If the SPN record is tied to a different account from the account running that instance of SQL Server, then you need to remove the wrong SPN record and add it back in for the correct user.

You can review the following articles for more information:

http://www.sqlservercentral.com/articles/Installation/cannotgeneratesspicontext/929/
http://support.microsoft.com/default.aspx?scid=kb;en-us;811889



Jeffrey Williams
Problems are opportunites brilliantly disguised as insurmountable obstacles.

How to post questions to get better answers faster
Managing Transaction Logs
Post #536331
Posted Thursday, July 17, 2008 3:12 PM
SSChasing Mays

SSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing Mays

Group: General Forum Members
Last Login: Thursday, January 2, 2014 10:30 AM
Points: 646, Visits: 731
When you try to connect to a SQL Server using SQL Server Management Studio, you get a connect to server window.
In that window there is another button on the Bottom right "options" Click on that and then use Named Pipes Protocol from the Network Prototol Drop Down List.


Maninder
www.dbanation.com
Post #536345
Posted Thursday, July 17, 2008 4:44 PM
Right there with Babe

Right there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with Babe

Group: General Forum Members
Last Login: Thursday, April 17, 2014 1:23 AM
Points: 732, Visits: 853
I am using SQL Server 2000 not 2005

Thanks and Regards!!

Raghavender Chavva
Post #536382
Posted Thursday, July 17, 2008 9:30 PM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, July 21, 2014 5:05 PM
Points: 2,644, Visits: 824
Raghavender (7/17/2008)
I am using SQL Server 2000 not 2005


Then you have posted in the wrong forum. You should have posted here:
http://www.sqlservercentral.com/Forums/Forum5-1.aspx

I would look at the SPN, as mentioned above. If it's not there, get it created.




Scott Duncan

MARCUS. Why dost thou laugh? It fits not with this hour.
TITUS. Why, I have not another tear to shed;
--Titus Andronicus, William Shakespeare
Post #536431
Posted Thursday, July 17, 2008 11:36 PM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 9:10 AM
Points: 416, Visits: 568
I agree with Jeffery :).. Setting SPN will solve the problem, coz the connection will use Kerberos authentication.

Regards..Vidhya Sagar
SQL-Articles
Post #536465
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse