Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Service Broker Messaging Issue with Real IP Expand / Collapse
Author
Message
Posted Tuesday, July 1, 2008 1:27 AM


Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Friday, June 27, 2014 8:02 AM
Points: 3,241, Visits: 4,996
I have a situation in which I want to communicate One server with another via Service Broker. The issue is that my Receiver Server is on Internet with Real IP. My Sender Server is on LAN with LAN IP. I can telnet the receiver server from sender server. The dialog initiates but the message resides in the sender transmission queue without any error. I am confused that why the transmission queus not showing / generating error.

I think, I cannot establish Service Broker communication with one Server with LAN IP and other with Real IP.

If I can, HOW?

And if I cannot, why there is no error in transmission Queue. Also, status in conversation_endpoint is also set to 'Conversing' (NO ERROR, and I dont know why.)

plz help.

Atif Sheikh


----------------------------------------------------------------------------------------------------------------------------------------------------------------------

Sometimes, winning is not an issue but trying.

You can check my BLOG here

Post #526357
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse