Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Memory Expand / Collapse
Author
Message
Posted Wednesday, May 7, 2008 3:40 PM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Wednesday, August 17, 2011 7:09 AM
Points: 869, Visits: 963
I am trying to figure out a way to increase memory usage on a server that has 3.5GB of memory. SQL Server is currenlty only using 1.6GB. I thought increasing the max memory setting would do it but it has not changed (after stop/starting SQL Server). There are no other applications running on the server. Here are my specs:

MSSQL Server 2000 Dev Edt. SP3
Windows 2003 Std. SP2
3.5GB RAM

Any advice is greatly appreciated!
Post #496748
Posted Wednesday, May 7, 2008 3:50 PM


SSC-Forever

SSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-Forever

Group: General Forum Members
Last Login: Today @ 10:05 AM
Points: 42,829, Visits: 35,961
What's the min memory setting?





Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #496754
Posted Wednesday, May 7, 2008 4:00 PM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Wednesday, August 17, 2011 7:09 AM
Points: 869, Visits: 963
Min setting is 0.
Post #496762
Posted Wednesday, May 7, 2008 11:10 PM


SSC-Forever

SSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-Forever

Group: General Forum Members
Last Login: Today @ 10:05 AM
Points: 42,829, Visits: 35,961
Then SQL will take just as much memory as it needs, up to the max as defined by the max server memory.

If there was a non-zero minimum, it would take at least that much memory.



Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #496858
Posted Thursday, May 8, 2008 7:20 AM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Wednesday, August 17, 2011 7:09 AM
Points: 869, Visits: 963
That's what I thought should happen. Although, I'm a little confused because we have another server that has much less usage and SQL Server is using close to 3.0GB of memory. Is there a Windows property that would prevent SQL Server from using more memory?
Post #497083
Posted Thursday, May 8, 2008 7:31 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 10:00 AM
Points: 5,330, Visits: 9,777
Are you using the /3GB switch in your boot.ini file?

John
Post #497096
Posted Thursday, May 8, 2008 8:07 AM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Wednesday, August 17, 2011 7:09 AM
Points: 869, Visits: 963
The /3GB switch is not in the boot.ini file. It's also not in the other server that is using 3GB of memory.

I did a little more digging and found that AWE is enabled on the server that is using 3GB of memory, and not enabled on the one using only 1.6GB. I'm fairly new to this environment so not sure why it's on for one and not the other. Would that make a difference? I thought AWE was used only if there's 4GB or more of physical memory.
Post #497123
Posted Friday, May 9, 2008 7:20 AM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Wednesday, August 17, 2011 7:09 AM
Points: 869, Visits: 963
I enabled AWE and set the max memory setting to 3GB. After rebooting, SQL Server is now using 3GB of memory. Thanks for your help!
Post #497852
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse