Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Report Builder Error Expand / Collapse
Author
Message
Posted Thursday, April 10, 2008 2:55 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, September 22, 2010 1:35 AM
Points: 28, Visits: 56
Hi,

I have a report builder application in my website.

On selecting the Report Builder,we get the report models.

On selecting on of the report models,i can add certain fields.

After adding the fields, i click on Filter button and add one more column which is a dropdown.

The problem i face is,after adding that column, I get the following error "The requested list could not be retrieved because the query

is not valid or a connection could not be made to the datasource" and drop down is not populated.





when i run d same query for in Query analyzer,data is retrieved in 10 secs,so it cannot be a time out problem....

I am not able to figure out exact problem.





Can anyone suggest me something for this.



Thanks.
Post #482848
Posted Thursday, April 10, 2008 9:42 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Thursday, October 23, 2008 1:43 PM
Points: 89, Visits: 206
Hello,

The report builder has to have a link to the table that is providing the drop down list.

You need to look in the sql view port and see if it is linked in.

Regards,

Terry
Post #483135
Posted Tuesday, April 29, 2008 5:05 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, November 07, 2013 2:39 PM
Points: 4, Visits: 103
I am getting the same error with my Source Fields that are set to ValueSelection of dropdown. Can you clarify on what you mean by "link to the table that is providing the drop down list." Isn't the link setup through binding the Column and in turn binging the Entity from the DSV? I have some Entities that go against Named Queries and others that hit a table in the DSV...this does not seem to make a difference.

Maybe the answer is in your statement "sql view port and see if it is linked in." Please help direct me to where to check this.

Thanks
Post #492534
Posted Wednesday, April 30, 2008 11:57 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Thursday, October 23, 2008 1:43 PM
Points: 89, Visits: 206

There should be a tool that let's you see what the select statement is that the Report is going to use.

That's what I mean by SQL view port.

Regards,

Terry
Post #493166
Posted Wednesday, July 02, 2008 7:31 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, October 13, 2009 4:04 AM
Points: 2, Visits: 24
Hi,
I have the same problem with filter drop downs not being populated in SSRS 2005, however in my case it is only happening to a single user which seems to rule out being a database link/security issue.

The user is in the same windows group as all others who have no problem. All the dropdowns are based on physical lookup tables which are referentially related to the main table.

I ran SQL Profiler while the user clicked on the filter dropdown and found no select from the drop down table, so it seems the request is not even getting to the database.

We use roaming profiles and when the user logs onto the PCs of those who can successfully view the filters, the problem still persists.
The above points lead me to think it may be an issue with a client component or setting related to report builder. Does anyone have an idea where I might look or what I could try changing/reinstalling?

Thanks in advance
Post #527311
Posted Wednesday, July 02, 2008 8:34 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, November 07, 2013 2:39 PM
Points: 4, Visits: 103
My problem was with permissions to the folder access in Report Manager. If I recall correctly the users that were having problems only had access to a folder under Home where their Models reside. The SQL data source lives in different folder under Home. Once I gave users Browse access to Home then it eliminated the error, seemed like a pathing situation related to permissions.

Hope this helps.
Post #527374
Posted Thursday, July 03, 2008 2:06 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, October 13, 2009 4:04 AM
Points: 2, Visits: 24
Thanks very much Mark! - that fixed the issue.
It is odd the user could still report on the database but just couldnt get the filters populated - seems the filters use a different route in accessing the dataconnection to the report generator.
Post #527830
Posted Tuesday, March 03, 2009 11:46 PM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Thursday, July 09, 2009 4:57 AM
Points: 58, Visits: 32
I m really interested to know, how do i incorporate the report builder in our own application, hiding the titles of report manager as well as report builder. I will be glad if u could help me out.
Post #667865
Posted Wednesday, March 04, 2009 8:30 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, November 07, 2013 2:39 PM
Points: 4, Visits: 103
Please give further specifics of what you are trying to do. We have incorporated Reporting Services reports (built through VS) into our site but do not use the Report Manager UI at all. We built a bridge class that is hitting the webservices for Reporting Services. Also have a button that will launch the Report Builder so a user can save a "custom" report.
Post #668308
Posted Wednesday, March 04, 2009 9:48 PM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Thursday, July 09, 2009 4:57 AM
Points: 58, Visits: 32
Thank you so much for your prompt reply. What exactly i m trying to do is that, i have created some of ma reports through the reporting services and analysis services, some of them were static and some we can customize through the report builder.I can view these reports properly in ma report manager and report builder,so i want to use these reports which i have created(static as well as Customized ones) in my own application in ASP.net and of course with the backend SQL(2005) and don't want to show the titles of report builder as well as report manager and would like to have some of my own custom controls for report builder, hiding the in-built controls of report builder.Thank u again for your time and reply.
Post #668880
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse