Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase ««12

how to configure sql 2000 server allow remote access Expand / Collapse
Author
Message
Posted Wednesday, January 16, 2008 7:54 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Sunday, September 18, 2011 6:11 PM
Points: 355, Visits: 299
I do not have ms sql 2005 installed in my server at all.
Post #443660
Posted Wednesday, January 16, 2008 8:12 AM
Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: Thursday, February 26, 2009 3:02 PM
Points: 515, Visits: 655
Frances,

My apologies for reading the posting too quickly.


All I have been able to find is a reference on page 388 in the ebook:

http://books.google.com/books?id=G2YqBS9CQ0AC&pg=PA388&lpg=PA388&dq=sql+server+enable+remote+connection+-2005+-desktop&source=web&ots=ZuMVFpFUaN&sig=6k4sCuHomxiLX_hDJsL95FRc31E#PPA388,M1

After executing:

exec sp_configure 'remote access', 1
reconfigure

The paragraph below also states "After enabling remote access, you'll need to shut down and restart each server".

There are also notes on how the database user(s) need to be configured on pages 388 and 389+

Hopefully these steps will help.





"Key"
MCITP: DBA, MCSE, MCTS: SQL 2005, OCP
Post #443688
Posted Wednesday, January 16, 2008 8:49 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, June 11, 2014 3:33 PM
Points: 112, Visits: 239
When you open SQL Server's "Server Network Utility" what protocols are enabled? It sounds like you need Named Pipes enabled as that is what your error message is complaining about. I have TCPIP and Named Piples enabled.

Can you connect to this SQL Server instance from a remote machine using Enterprise Manager?

Another common problem I've seen is DNS server sending your connection requests to the wrong machine. I have a server right now that everytime I try to connect to it from one area of our network I actaully connect to a sales person's laptop and not the server I want. The DNS folks are looking into it, but most likely the DNS tables are just messed up. I figured it out by using remote desktop to make the connection and realized it was not the machine I was expecting. OK, I also kicked the guy off of is machine when I logged on and he was logged out, but that story is for another day...

I now you said you can't install SQL Server 2000 SP4 because you are running on NT 4.0, how about SQL Server SP3. I know on Windows2000 you had to be on at least SQL Server SP3 otherwise the network connections were disabled. I'm not sure what SQL Server's support is for NT 4.0.

-Tony

Post #443734
Posted Wednesday, January 16, 2008 9:00 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: General Forum Members
Last Login: Today @ 3:59 AM
Points: 39,892, Visits: 36,238
You said that
http://computername/HRHSKeyContact/HRHSKeyContact.aspx
works, but
http://computername/HRHSKeyContact/HRHSKeyContact.aspx?hid=2
doesn't.

If you look at the aspx page, what's done differently if the querystring is passed, compared to not passed. Can you post the relevant portions of the code from the aspx page?

Is the web server on the same machine as the SQL server?
Is SQL Native access client installed on the web server (if it is, it would explain why you're getting a 2005-related error with a 2000 server.)

The particular error that you're getting is the generic 'server not found or access is denied' message that a 2005 client library will generate if it can't connect. Often is has nothing to do with remote access not been enabled. Especially on a SQL 2000 machine, where remote access is enabled by default.



Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #443742
Posted Wednesday, January 16, 2008 9:36 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Sunday, September 18, 2011 6:11 PM
Points: 355, Visits: 299


<asp:DetailsView ID="dvInfo" runat="server" DefaultMode=ReadOnly AutoGenerateRows="False"
DataSourceID="dsKeyContact" HeaderText="Review the info and make the necessary change" DataKeyNames="HID"
Width="692px" OnItemUpdated="dvInfo_ItemUpdated" OnDataBound="dvInfo_DataBound" Font-Bold="True" Font-Size="Large">
























<asp:DropDownList id="dpBusUnit" runat="server"
DataSourceID="dsBusUnit"

DataTextField="BusUnit" DataValueField="BusUnit"
SelectedValue='












<asp:DropDownList id="dpDept" runat="server"
DataSourceID="dsDept"

DataTextField="Dept" DataValueField="Dept"
SelectedValue='


















<asp:CustomValidator ID="ValidPhoneLength" runat="server" ControlToValidate =txtOfficePhone ClientValidationFunction="ValidPhoneLenght"
ErrorMessage="The length of the phone should not more than 10">*
















































<asp:RegularExpressionValidator ID="vrREmail" runat="server" ErrorMessage="Check the email again. It must contain @" ControlToValidate =txtEmail
ValidationExpression="\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*">*
















"
SelectCommand="SELECT [HName], [Title], [BusUnit], [Department], [OfficePhone], [Mobile], [Pager], [Home], [AlternatePhone], [Email], [LastUpdate], [HID] FROM [KeyContactPhone] WHERE ([HID] = @HID)"
UpdateCommand="UPDATE KeyContactPhone SET Title =@Title, HName =@HName, BusUnit =@BusUnit, Department =@Department, OfficePhone =@OfficePhone, Mobile =@Mobile , Pager =@Pager, Home =@Home, AlternatePhone =@AlternatePhone, Email =@Email WHERE ([HID] = @HID)" ProviderName="


















"
SelectCommand="SELECT Dept from Dept order by Dept " ProviderName="



"
SelectCommand="SELECT BusUnit from BusUnit order by BusUnit " ProviderName="





When you open SQL Server's "Server Network Utility" what protocols are enabled? It sounds like you need Named Pipes enabled as that is what your error message is complaining about. I have TCPIP and Named Piples enabled.

The 'remote access is set up as 1 already.

You said that
http://computername/HRHSKeyContact/HRHSKeyContact.aspx
works, but
http://computername/HRHSKeyContact/HRHSKeyContact.aspx?hid=2
doesn't.

What I tried to say is the web server did not have problem to display the web site.
Here is my aspx code. The query string should not be issue. Since
http://localhost/HRHSKeyContact/HRHSKeyContact.aspx?hid=2
will show the result as I expected.

Post #443787
Posted Wednesday, June 3, 2009 2:39 AM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Friday, September 19, 2014 8:15 AM
Points: 1,202, Visits: 1,937
Dear Frances I have also the same problem

Failed to connect to server ajayg\ajayg2000. (Microsoft.SqlServer.ConnectionInfo)

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)


Yet I am not doing it using programming I am doing directly to sql server.


Thanks

Post #727976
Posted Saturday, June 15, 2013 5:50 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, June 15, 2013 5:47 AM
Points: 1, Visits: 0
Thanks a lot...You saved my time...
Post #1463843
« Prev Topic | Next Topic »

Add to briefcase ««12

Permissions Expand / Collapse