Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Database Mail Not starting Expand / Collapse
Author
Message
Posted Thursday, July 6, 2006 10:39 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, November 24, 2010 1:35 PM
Points: 1, Visits: 9
I've installed SQL Server 2005 on 3 different servers and have finally installed it on my production server. I went to configure Database Mail and get the expected dialog "Database mail depends on Service Broker...Do you want to enable Service Broker on msdb"?

I select yes and then nothing happens. It just hangs. I've let it run for over an hour. I've tried the Surface Area Configuration tool and in the logs I see the following,

"Setting database option ENABLE_BROKER to ON for database msdb."

Still everytime I go to setup a profile I get the same, "do you want to enable Service Broker" message and then hang.

I've done this on all my other servers without problem.

Thanks.
Post #292588
Posted Monday, July 10, 2006 8:00 AM
SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Friday, May 18, 2007 3:36 PM
Points: 10,039, Visits: 1
No one has responded to this topic yet. Even if you don't have a complete answer, the original poster will appreciate any thoughts you have!
Post #293145
Posted Thursday, August 24, 2006 3:06 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, July 8, 2010 7:34 AM
Points: 5, Visits: 16

Enabling the broker requires exclusive rights to the database.
Put MSDB in single-user mode and then fire the command:

ALTER DATABASE [msdb] SET ENABLE_BROKER

Post #303972
Posted Friday, September 14, 2007 1:04 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, July 3, 2014 4:24 AM
Points: 18, Visits: 45
This last solution must work, but stopping SQL Server Agent works too, at least for me.
Thank you for the idea.
Post #399189
Posted Thursday, June 30, 2011 3:15 PM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 8:17 AM
Points: 298, Visits: 335
We ended up with a corupt msdb after a power outage. Restored the msdb backup, and noticed that emails were not going out after jobs completed. Went into database mail, got the "must enable service broker" message, and experienced the hangup described above. Simply stopping SQL Server Agent before going back into setup Mail fixed the problem.

Why wouldn't Service Broker be enabled in the backed up copy of msdb? All was working for months before, and a the backup was a few hours old.



Student of SQL and Golf, Master of Neither
Post #1134732
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse