Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Starting SQL Server Agent - WMI Provider Error - The remote procedure call failed. Expand / Collapse
Author
Message
Posted Tuesday, August 12, 2014 1:13 PM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Thursday, August 21, 2014 7:39 AM
Points: 301, Visits: 199
So I was adding a new named instance to one of my servers. These instances are just data repositories that get rebuilt every night, so they're not backed up or anything. I set the SQL agent to disabled while setting it up.

I was using the copy database wizard and realized the package wouldn't work because the agent wasn't running (error told me as much). When I try to go into SQL Server Configuration Manager and change the start mode from "disabled" to "manual", when I hit apply I get this error:

WMI Provider Error
The remote procedure call failed. [0x800706be].

This is a Windows Server 2008 R2 enterprise server running SQL Server 2008 R2 SP2.

Anyone seen that before?
Post #1602436
Posted Tuesday, August 12, 2014 2:25 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, August 29, 2014 10:04 AM
Points: 44, Visits: 98
SQL Server Agent is a dependent service on SQL Server Service. Try getting into 'Service Manager' and change it to automatic.
Post #1602474
Posted Wednesday, August 13, 2014 6:25 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, December 22, 2014 2:05 AM
Points: 178, Visits: 260
Start your MSSQLSERVER standard services for that follow Open Administrative task then Services then Select Standard Services tab->SQL Server Agent Service then u r done.
Post #1602697
Posted Wednesday, August 13, 2014 8:12 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Thursday, August 21, 2014 7:39 AM
Points: 301, Visits: 199
I ended up re-installing the instance. Works fine now. Thanks though gents!
Post #1602757
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse