Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Unspecified error using ADO command to update a varchar max field Expand / Collapse
Author
Message
Posted Friday, July 25, 2014 8:10 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, September 8, 2014 1:23 PM
Points: 6, Visits: 79
Hello

This is a tricky one, and my first post to this forum so appollogies if I'm in the wrong place.

We have a SQL Server 2008 database for handling help desk calls. When necessary the users will paste the entire contents of an email into a text box on the main form. This can sometimes include graphics etc. which get stripped. The email client is Outlook 2007 and the frontend is built in MS Access and uses ADO (2.8) commands to handle updates. The backend parameter and field is varchar(max).

The problem is that, occasionally, when the user clicks save they get an unspeciifed error occurring on the command.execute line.

This problem can't be reproduced on the dev machines which run with Office 2003.

We managed to isolate a single character that produces the error every time in a 2007 environment. This character is ASCII 234, looks like a "|" or sometimes "ê" depending on font etc.

I have tried stripping all characters with an ASCII code greater than 128. This makes no difference. Also tried changing to nvarchar and this didn't help either.

Anyone seen this before or have any idea what might be causing it?

Thabnks

Mark
Post #1596231
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse