Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Setting arithabort on in SSRS Expand / Collapse
Author
Message
Posted Thursday, July 24, 2014 4:20 PM


Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Yesterday @ 10:47 AM
Points: 56, Visits: 355
Anyone know if this is possible? Have been consistently using a plan which does not have arithabort even though I set the option in the proc.
When run manually in ssms, a plan gets create with arithabort.
Even after I set arithabort on in start of stored proc, when I run it on ssrs, it is reusing the plan without the arithabort.
Have already rewrote the proc with dynamic sql.
Also, I have passed parameters to local variables.

Regards
MadTester/Madadmin
Post #1596039
Posted Tuesday, July 29, 2014 3:16 AM


Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Yesterday @ 10:47 AM
Points: 56, Visits: 355
For anyone googling, the solution is that SSRS does not explicitly set the arithabort option.
It will inherit whatever is set at the DB level.
In my case, the DB's have been upgraded from 2000 to 2008 so the arithabort option is off as it was defaulted to OFF.
You should not have the issue with DB's created with 2008 since it defaults to on, but if DB was created using SQL2000, would have defaulted to OFF.

Post #1597197
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse