Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

DTEXEC returning Exit Code 5 Expand / Collapse
Author
Message
Posted Monday, March 31, 2014 3:22 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, April 3, 2014 5:55 AM
Points: 15, Visits: 31
I have a simple SSIS package that retrieves data from a formatted Excel spreadsheet. The Stored Procedure has the appropriate permissions and executes correctly. xp_cmdshell is active and the user group has execute permissions. The spreadsheet source location has the permissions set. I am the originator of the package and it works correctly for me on any desktop in the domain. When another user tries to execute the SSIS package, the package exit code of 5 (The utility was unable to load the requested package. The package could not be loaded.) comes back.

msdb roles for db_ssisoperator, db_ssisadmin, and db_ssisltduser have been assigned to the user group.

What permission am I missing? This is getting frustrating.

Thanks in advance
Scott
Post #1556738
Posted Tuesday, April 1, 2014 10:29 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: 2 days ago @ 2:57 PM
Points: 1,194, Visits: 2,211
What's the package protection level ?

--
SQLBuddy
Post #1557102
Posted Tuesday, April 1, 2014 11:58 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, April 3, 2014 5:55 AM
Points: 15, Visits: 31
Currently set to do not save sensitive data.
Post #1557149
Posted Tuesday, April 1, 2014 1:17 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: 2 days ago @ 2:57 PM
Points: 1,194, Visits: 2,211
Did you create a server proxy account for the non-sysadmin users to run XP_cmdshell ? Are you a sysadmin on the server and is it not possible to schedule the package to run by your ID ?

--
SQLBuddy
Post #1557176
Posted Tuesday, April 1, 2014 2:25 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, April 3, 2014 5:55 AM
Points: 15, Visits: 31
1. This package is on-demand execution triggered from an application. Setting it as a job won't work.
2. I am sysadmin on the server. The users will be activating the process. This is the main issue.
3. Will a proxy fix this issue? I have used the login context before with other applications, and they are functioning correctly.
Post #1557200
Posted Tuesday, April 1, 2014 5:51 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: 2 days ago @ 2:57 PM
Points: 1,194, Visits: 2,211
Scott Nicholson-254313 (4/1/2014)
1. This package is on-demand execution triggered from an application. Setting it as a job won't work.
2. I am sysadmin on the server. The users will be activating the process. This is the main issue.
3. Will a proxy fix this issue? I have used the login context before with other applications, and they are functioning correctly.

It could fix it .. First create the server proxy account (SSMS --> SQL Server Properties --> Security )

Check this

http://sqlblog.com/blogs/tibor_karaszi/archive/2007/08/23/xp-cmdshell-and-permissions.aspx

--
SQLBuddy
Post #1557282
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse