Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSAS Cube on one server and SQL Server DB on another - Connection Issues Expand / Collapse
Author
Message
Posted Tuesday, March 25, 2014 5:37 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, April 8, 2014 3:16 PM
Points: 7, Visits: 43
Hi Guys - I data modeled a star schema data mart in SQL Server 2008 and I've created a cube in BIDS for analysis services in VS 2008. The data mart database is on one server (SQL 2008) and the AS is on another (2005 AS server). I have deployed the cube from BIDS with errors, and the cube does get built on the AS server as I can log into the AS server via SSMS and seee the AS db with the associated cube, etc.

The problem I am experiencing is that when I try to Deploy from BIDS, or Process from SSMS, I receive the following error


Internal error: The operation terminated unsuccessfully.
Internal error: The operation terminated unsuccessfully.
The datasource , 'FinancialDB', contains an ImpersonationMode that is not supported for processing operations.
Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'FinancialDB', Name of 'FinancialDB'.
Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Dim Versions', Name of 'Dim Versions' was being processed.
Errors in the OLAP storage engine: An error occurred while the 'Version Type' attribute of the 'Dim Versions' dimension from the 'CARCube' database was being processed.
Server: The operation has been cancelled.


Regarding the IMPERSONATIONMODE, I have tried 3 out of the 4 options: Inherit, User the credentials of the current user, and use the service acccount. Not one of them works for me. I tried these with the AS Server DA.

Also, I'm using the default native sql server connection profile. I also tried the OLE DB for SQL Server connection profile.

I have logged into the datamart server and instance to builed the datamart via SSMS. I have also logged into the Analytical Services server via SSMS and I can see the cube I built.

It appears the Analysis Services server can not connect with the SQL DB server. I am not the DA for either server and I've spoken to each and they both have said I should speak to the DA of each server to solve the issue as the DAs are not the same. The AS DA said I should ask the SQL DB DA to set me up with a login id and password instead of windows authentication, which is how most logins are setup at my company. This is the fourth option of the IMPERSONIATIONMODE mentioned above.

Two questions: 1) Has anyone experienced this and solved it WITHOUT ANY ADJUSTMENTS to the IMPERSONATION Information? 2) Typically, who would be responsible for solving this issue? The SQL DB DA or the AS DA? I need to pin one of these folks down so I can get this resolved and start browsing my cube.

Thank you for any help in advance and please be aware that I have tried the IMPERSONATION settings many times in conjunction with the AS DA at our company who is very knowledgable.

Thanks
Paul
Post #1554725
Posted Wednesday, March 26, 2014 4:30 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: 2 days ago @ 11:20 PM
Points: 13,252, Visits: 10,133
Strange. You should be able to use the service account impersonation setting. It's what we use here at the current project.
Make sure the SSAS service account has read permissions on the SQL Server database.




How to post forum questions.
Need an answer? No, you need a question.
What’s the deal with Excel & SSIS?

Member of LinkedIn. My blog at LessThanDot.

MCSA SQL Server 2012 - MCSE Business Intelligence
Post #1554861
Posted Wednesday, March 26, 2014 6:42 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, April 8, 2014 3:16 PM
Points: 7, Visits: 43
It has been resolved. Thanks
Post #1555236
Posted Thursday, March 27, 2014 1:00 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: 2 days ago @ 11:20 PM
Points: 13,252, Visits: 10,133
plmarshall (3/26/2014)
It has been resolved. Thanks


What was the issue?




How to post forum questions.
Need an answer? No, you need a question.
What’s the deal with Excel & SSIS?

Member of LinkedIn. My blog at LessThanDot.

MCSA SQL Server 2012 - MCSE Business Intelligence
Post #1555291
Posted Tuesday, April 1, 2014 6:52 PM This worked for the OP Answer marked as solution
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, April 8, 2014 3:16 PM
Points: 7, Visits: 43
The issue was I had to log in using OLE DB SQL Server with "auto" credentials, then I needed to log into the AS server via my company's window's login. No windows authentication for the AS server.

Paul
Post #1557286
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse