Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase «««123

cluster failover --memory Expand / Collapse
Author
Message
Posted Monday, March 10, 2014 6:12 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 5:41 AM
Points: 419, Visits: 2,122
CLR is enabled and the server holds linked servers. Maxdop setting is 4. For CPU settings, both processor affinity mask and i/o affinity mask were checked. We also have extended stored procs on the servers.
Post #1549532
Posted Tuesday, March 11, 2014 12:33 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 5:38 AM
Points: 6,760, Visits: 14,410
How physical do you have and what is max server mem set to?

-----------------------------------------------------------------------------------------------------------

"Ya can't make an omelette without breaking just a few eggs"
Post #1549565
Posted Tuesday, March 11, 2014 6:25 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 5:41 AM
Points: 419, Visits: 2,122
500 GB RAM. 425 GB max memory setting.
Post #1549694
Posted Tuesday, March 11, 2014 9:44 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Tuesday, December 16, 2014 9:57 AM
Points: 1,194, Visits: 2,234
muthyala_51 (3/10/2014)
CLR is enabled and the server holds linked servers. Maxdop setting is 4. For CPU settings, both processor affinity mask and i/o affinity mask were checked. We also have extended stored procs on the servers.


Did you check for any CPU pressure on the server ? Especially due to MAXDOP. Check for CX_Packet WAITS.

You should try to tune Worker Threads and MAXDOP settings for further troubleshooting.

--
SQLBuddy




Post #1549820
Posted Tuesday, March 11, 2014 10:29 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Tuesday, December 16, 2014 9:57 AM
Points: 1,194, Visits: 2,234
What's your SQL Build no ? Also try to collect these counters (Perfmon) which gives us more insight ..

Processor – %Privileged Time
Processor – %Processor Time
Processor – %Interrupt Time
Processor – Interrupts\Sec
Process(sqlservr) - %Processor Time
System – Processor Queue Length
System - Processor Queue Length
System - Context Switches/sec
SQLServer:SQL Statistics Compilations/sec
SQLServer:SQL Statistics Re-Compilations/sec

--
SQLBuddy
Post #1549844
Posted Tuesday, March 11, 2014 10:33 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 5:38 AM
Points: 6,760, Visits: 14,410
muthyala_51 (3/11/2014)
500 GB RAM

Bit of an odd figure, i'm assuming that's 512GB RAM?

muthyala_51 (3/11/2014)
425 GB max memory setting.

Given the fact you have a lot of CLR and ext stored proc, etc i would lower the max memory setting a little. Monitor the server and if necessary increase or decrease again. My temptation would be to lower it to 384GB and then monitor.

You have to reserve enough RAM for the following

Ext Stored Proc
CLR
Windows OS mem manager
Any other apps running on the server


-----------------------------------------------------------------------------------------------------------

"Ya can't make an omelette without breaking just a few eggs"
Post #1549847
Posted Thursday, March 13, 2014 10:39 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 5:41 AM
Points: 419, Visits: 2,122
muthyala_51 (3/11/2014)
425 GB max memory setting.
Given the fact you have a lot of CLR and ext stored proc, etc i would lower the max memory setting a little. Monitor the server and if necessary increase or decrease again. My temptation would be to lower it to 384GB and then monitor.

You have to reserve enough RAM for the following

Ext Stored Proc
CLR
Windows OS mem manager
Any other apps running on the server


But during the downtime all the memory was able to windows. As the sql server was just trying to grab memory from the windows after restart.
Post #1550817
« Prev Topic | Next Topic »

Add to briefcase «««123

Permissions Expand / Collapse