Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSIS 2012 Project cant save poackage Expand / Collapse
Author
Message
Posted Tuesday, January 21, 2014 4:58 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
More than one developer working on one SSIS 2012 project.
Project protection level = dont save sensitive
Package protection level = dont save sensitive

I can create a new text file in the foilder where we save the packages but when I edit the package I can not save it?

When I log in as a different developer I can open and save the package.

When I log in as myself and go to save the package. A pop up file save box appears and when you click save to overwrite the original file you get an access denied message.

Very weird. Any suggestions gratefully received

Cheers
E
Post #1532967
Posted Tuesday, January 21, 2014 5:16 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 8:58 AM
Points: 5,077, Visits: 8,918
Have you checked your NTFS permissions on the package file?

John
Post #1532973
Posted Tuesday, January 21, 2014 5:32 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
On the folder that contains the project it comes up with a grey tick in the read only so I know some files \ folders undernmeath are read only.

So the top level has a sub foider for the project and a solution. The project folder is the one that comes up with a grey tick in the read only. I can change this but it does not seem to stick? i.e five minutes later its back as before.

All the packages in the project folder are not read only and thats where I will be saving the file.

Thanks
E
Post #1532981
Posted Tuesday, January 21, 2014 5:34 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
The Bin and Obj folders I just cant change that away from a greyed tick in the read only?

E
Post #1532983
Posted Tuesday, January 21, 2014 5:36 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 8:58 AM
Points: 5,077, Visits: 8,918
What are the permissions on ther actual file itself?

When changing NTFS permissions, you either need to change them at the level they were originally set and cascade them down, or change them directly on the object in question and disable inheritance.

John
Post #1532984
Posted Tuesday, January 21, 2014 6:18 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
The individual dtsx file is not showing as read only.
I can create or save a package as with a different name.

I cant run them from the designer now. It pops up a save as window before you can run it,

Puzzled.
Post #1533008
Posted Tuesday, January 21, 2014 7:14 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 8:58 AM
Points: 5,077, Visits: 8,918
It's not a question of whether the file is read-only - it's whether you have permission to change it. Right-click on the file and choose Security. If you (or a group you are a member of) appear in the list of accounts with permissions with Change (I can't remember whether that's the exact name of the permission) then you should be able to save the package.

John
Post #1533044
Posted Tuesday, January 21, 2014 7:19 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
Having looked at another project I have created the bin folder and development subfolder both appear to have the same settings?

The only thing I can think about is the project we are having problems with the other developer was the first one to put it on the file system where it is stored as a project.

E
Post #1533050
Posted Tuesday, January 21, 2014 8:24 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Wednesday, March 12, 2014 9:59 AM
Points: 692, Visits: 754
after a lot of effort this was resolved. Not quite sure which change did the trick but yes it was NTFS permissions based issue.

Quite a learning experience.
Thanks
Post #1533116
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse