Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

DatabaseMail Expand / Collapse
Author
Message
Posted Saturday, December 14, 2013 2:15 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 7:42 PM
Points: 435, Visits: 436
I am trying to configure database mail through my gmail. Before it works fine to me but now when I am sending test mail it is not working. The port no I am using is 587. I am using server name
smtp.gmail.com
Post #1522970
Posted Sunday, December 15, 2013 7:38 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 1:11 PM
Points: 7,019, Visits: 12,909
"It's not working" doesn't really help us to help you in any way.
What's the exact error message you receive?




Lutz
A pessimist is an optimist with experience.

How to get fast answers to your question
How to post performance related questions
Links for Tally Table , Cross Tabs and Dynamic Cross Tabs , Delimited Split Function
Post #1523026
Posted Sunday, December 15, 2013 7:48 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: General Forum Members
Last Login: Today @ 12:05 PM
Points: 36,710, Visits: 31,158
ramana3327 (12/14/2013)
I am trying to configure database mail through my gmail. Before it works fine to me but now when I am sending test mail it is not working. The port no I am using is 587. I am using server name
smtp.gmail.com


For that question, the answer would be to find out what changed. If it was working before and now it doesn't, then something changed. Find that and you'll have your answer.


--Jeff Moden
"RBAR is pronounced "ree-bar" and is a "Modenism" for "Row-By-Agonizing-Row".

First step towards the paradigm shift of writing Set Based code:
Stop thinking about what you want to do to a row... think, instead, of what you want to do to a column."

(play on words) "Just because you CAN do something in T-SQL, doesn't mean you SHOULDN'T." --22 Aug 2013

Helpful Links:
How to post code problems
How to post performance problems
Post #1523030
Posted Monday, December 16, 2013 7:47 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 7:42 PM
Points: 435, Visits: 436
Actually, I install SQLServer2008R2 developer edition. At that time I configured database mail it works fine to me. After I uninstalled and and re-install the instance again. But this time when I tried to configured the database mail again, the mail is not going. When I see database mail log there is the following message
The mail couldn't send to the recipients because of the mail server failed. Can't send mails to mail server. The SMTP server requires a secure connection or the client was not authenticated. The server response was 5.5.1. Authentication required.
Post #1523233
Posted Monday, December 16, 2013 7:48 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 7:42 PM
Points: 435, Visits: 436
Actually, I install SQLServer2008R2 developer edition. At that time I configured database mail it works fine to me. After I uninstalled and and re-install the instance again. But this time when I tried to configured the database mail again, the mail is not going. When I see database mail log there is the following message
The mail couldn't send to the recipients because of the mail server failed. Can't send mails to mail server. The SMTP server requires a secure connection or the client was not authenticated. The server response was 5.5.1. Authentication required.
Post #1523234
Posted Monday, December 16, 2013 7:58 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Today @ 1:46 PM
Points: 12,876, Visits: 31,788
5.5.1 implies you did not set up your db mail to send the basic authentication to have the username and password:



Lowell

--There is no spoon, and there's no default ORDER BY in sql server either.
Actually, Common Sense is so rare, it should be considered a Superpower. --my son
Post #1523243
Posted Wednesday, December 18, 2013 3:30 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 7:42 PM
Points: 435, Visits: 436
I took the first option use the windows authentication
Post #1524382
Posted Thursday, December 19, 2013 2:03 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 7:42 PM
Points: 435, Visits: 436
If I took Basic authentication and gave gmail account as user name & Gmail account password in the password then it is working fine but if I use windows authentication it is not working. so that means the remaining two options doesn't work.
Instead of gmail account if you took yahoo account shall we use the same port number?
Thanks
Post #1524796
Posted Friday, December 20, 2013 2:53 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Today @ 1:46 PM
Points: 12,876, Visits: 31,788
[quote]ramana3327 (12/19/2013)
If I took Basic authentication and gave gmail account as user name & Gmail account password in the password then it is working fine but if I use windows authentication it is not working. so that means the remaining two options doesn't work.
Instead of gmail account if you took yahoo account shall we use the same port number?
Thanks[/quotemail settings depend on your server.

for windows authentication the mail server would be inside your lan -an exchange server.forexample.
to allow anonymous authentication typically thenmail server adds your sql servers IP to its white list and passes any mailnat all coming from that macchine.

Most smtp servers (all?!) SUPPORT basic authentication so thats thenmost common.

Not sure on the mail settings for yahoo mail youd have to goofle it.


Lowell

--There is no spoon, and there's no default ORDER BY in sql server either.
Actually, Common Sense is so rare, it should be considered a Superpower. --my son
Post #1524904
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse