Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Can not enter in sql server under sa Expand / Collapse
Author
Message
Posted Friday, December 06, 2013 9:41 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, December 14, 2013 8:12 AM
Points: 4, Visits: 86
I had by default installed express msmss with windows mode. But now I need mixed mode of authentication. I have tuned the server and checked in its properties - mixed mode.
I had also enabled (executed the query ALTER LOGIN). I have entered the same paasword into sa properties. I have entered under sa - but there is a mistake in the journal that says that The server supports only windows authentication mode.
I have cheked and restarted server several times. Under administrator rights and under not.
But it doesn't work still.
I make it because i need to connect to sql server from the Sql Developer Oracle.
Post #1520651
Posted Friday, December 06, 2013 1:21 PM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Friday, January 03, 2014 3:52 PM
Points: 6,066, Visits: 5,277
So locally can you log in with SA or not? But externally you can't. I didn't quite catch it..

CEWII
Post #1520731
Posted Wednesday, December 11, 2013 7:24 AM


SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Today @ 11:21 AM
Points: 153, Visits: 946
If you actually did change the authentication mode to mixed mode, entered a new password for sa and then restarted SQL Server, this has to work.
So something must have gone really wrong / been overlooked.

You can check the auth mode in the registry:

Open regedit.exe
Go to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\<INSTANCE NAME>\MSSQLServer where <INSTANCE NAME? is the name of the MS-SQL instance.
Locate the field "LoginMode"
a value of "2"is Mixed Mode Authentication


Andreas

---------------------------------------------------
MVP SQL Server
Microsoft Certified Master SQL Server 2008
Microsoft Certified Solutions Master Data Platform, SQL Server 2012
www.insidesql.org/blogs/andreaswolter
www.andreas-wolter.com
Post #1521894
Posted Wednesday, December 11, 2013 9:38 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, March 31, 2014 10:26 PM
Points: 16, Visits: 203
Check if the SA account is disabled. If it is, then enable it using below SQL query

Use Master
Go

ALTER LOGIN [sa] WITH PASSWORD='StrongPassword'
Go

Chandu
[color=Blue]If you dont have question, you wont get answer[/color]
Post #1522131
Posted Wednesday, December 11, 2013 9:42 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, March 31, 2014 10:26 PM
Points: 16, Visits: 203
Please use below query to enable SA login and change SA password.
Use Master
Go
ALTER LOGIN [sa] ENABLE
go
ALTER LOGIN [sa] WITH PASSWORD=N'StrongPassword'
Go

Chandu
Post #1522132
Posted Monday, December 16, 2013 10:56 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Thursday, March 27, 2014 6:04 PM
Points: 450, Visits: 991
sounds like you never created one sa account in your server., changing it to mixewd mode after installation does not create sa account automatically ! you should have a option to create either when you install or create it after install.

Login with domain or windows mode and create sa and login then.





--SQLFRNDZ
Post #1523352
Posted Monday, December 16, 2013 11:04 AM


SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Today @ 11:21 AM
Points: 153, Visits: 946
it's not possible to NOT "install" sa. The only diofference is, whether sa is actually enabled - which he said he did manually - and whether the password is known
Let's wait for the answers on the proposed queries


Andreas

---------------------------------------------------
MVP SQL Server
Microsoft Certified Master SQL Server 2008
Microsoft Certified Solutions Master Data Platform, SQL Server 2012
www.insidesql.org/blogs/andreaswolter
www.andreas-wolter.com
Post #1523363
Posted Tuesday, December 17, 2013 9:52 PM


SSChasing Mays

SSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing Mays

Group: General Forum Members
Last Login: Yesterday @ 4:23 PM
Points: 604, Visits: 480
If you're an admin on the box, you can get in anyways and fix any mistakes you have.

.
Post #1523935
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse