Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase ««123»»

ssis script task throws error when run from sql agent job Expand / Collapse
Author
Message
Posted Friday, November 15, 2013 5:17 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 4, 2014 12:04 PM
Points: 33, Visits: 113
The file and folder has everyone full control set.
The account is MyDomain\MyProxy


Forum User
Post #1514674
Posted Friday, November 15, 2013 6:18 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 4, 2014 12:04 PM
Points: 33, Visits: 113
yes, my file and folder has everyone full control.

I checked the event viewer. It is showing the following error:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {Fab1234D-1588-4BA3-92D4-123431235f3r} and APPID {34B12342-123D-4824-B42E-1234AE61BB05} to the user MyDomain\MyAcct SID (S-1-5-21-1234565741-12412345839-921234558-432120) from address LocalHost (Using qwer). This security permission can be modified using the Component Services administrative tool.

How/What do I need to modify using Component Services administrative tool?

I opened Component Services administrative tool, but did not find an application with id {Fab1234D-1588-4BA3-92D4-123431235f3r} or {34B12342-123D-4824-B42E-1234AE61BB05} under DCOM Config.

Thanks.


Forum User
Post #1514700
Posted Friday, November 15, 2013 6:20 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, July 4, 2014 12:04 PM
Points: 33, Visits: 113
Yes, my folder and files have every one full control.

I checked the event viewer. It is showing the following error: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {FDC1234D-1588-4BA3-92D4-42C12345D7D} and APPID {37g1234-693D-4824-B42E-1234AE61df05} to the user MyDomain\MyAcct SID (S-1-5-21-7654321-1241591234-123409458-121234) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.


I opened Component Services administrative tool, but did not find an application id {FDC1234D-1588-4BA3-92D4-42C12345D7D} or {37g1234-693D-4824-B42E-1234AE61df05} under DCOM Config.

How/what do I need to modify using Component Services administrative tool?


Forum User
Post #1514701
Posted Friday, November 15, 2013 6:38 AM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Today @ 9:07 AM
Points: 1,787, Visits: 5,726
A quick search of the registry will tell you that class id is for the DTS server, so another quick look under the DCOM Config section of Component Services and you will find

Microsoft SQL Server Integration Services 11.0

If you open the properties of that, you will find the AppId from your error message - then you know you have found it, so go ahead and grant activation to the user account in your proxy settings.


MM


  • MMGrid Addin
  • MMNose Addin


  • Forum Etiquette: How to post Reporting Services problems
  • Forum Etiquette: How to post data/code on a forum to get the best help - by Jeff Moden
  • How to Post Performance Problems - by Gail Shaw

  • Post #1514708
    Posted Monday, November 18, 2013 5:14 AM
    SSC Rookie

    SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

    Group: General Forum Members
    Last Login: Friday, July 4, 2014 12:04 PM
    Points: 33, Visits: 113
    I did the following:
    Opened Component Services,Expand Component Service->My Computer->DCOM Config, Locate “Microsoft SQL Server Integration Services 11.0” Rt click and select “Properties” Select the “Security” tab, In Launch and Activate Permissions, then “Edit” Grant “Local Launch”, “Local Activation” permissions for SQL Agent Service / proxy account MyDomain\MyAcct, Restarted SQL Agent and tried again.

    Now the error in the event viewer is gone, but I still get the error in sysssislog: Source: Set FS File Parameters Script Task: Exception has been thrown by the target of an invocation.

    What else needs to be changed?


    Forum User
    Post #1515185
    Posted Tuesday, November 19, 2013 10:29 AM
    SSC Rookie

    SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

    Group: General Forum Members
    Last Login: Friday, July 4, 2014 12:04 PM
    Points: 33, Visits: 113
    I am loosing hope, please respond. I am sure many people are using this in their ETL.



    Thanks.


    Forum User
    Post #1515674
    Posted Tuesday, November 19, 2013 12:52 PM


    SSCommitted

    SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

    Group: General Forum Members
    Last Login: Today @ 9:07 AM
    Points: 1,787, Visits: 5,726
    You need to find out what the actual error message is.

    It should be output in the window at the bottom of the package designer (Output window) when you run the package in debug mode.

    If not, try adding a try ... catch round the code in your script task "Set FS File Parameters Script Task" and debug that - set a breakpoint in the code to view the error...


    MM


  • MMGrid Addin
  • MMNose Addin


  • Forum Etiquette: How to post Reporting Services problems
  • Forum Etiquette: How to post data/code on a forum to get the best help - by Jeff Moden
  • How to Post Performance Problems - by Gail Shaw

  • Post #1515744
    Posted Wednesday, November 20, 2013 6:03 AM
    SSC Rookie

    SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

    Group: General Forum Members
    Last Login: Friday, July 4, 2014 12:04 PM
    Points: 33, Visits: 113
    When I run the package in debug mode using Visual studio, it works fine, no errors.
    When I run it in a scheduled job in SQL Agent using a service account I get this error. I wrapped my code in the script task in a try catch block and I get "Access to the path ... denied", the error message is copied below. I have set everyone full control on the files and folders on E drive.
    Error Message:
    Executed as user: MyDomain\MyServiceAcct . Microsoft (R) SQL Server Execute Package Utility Version 11.0.2100.60 for 32-bit Copyright (C) Microsoft Corporation. All rights reserved. Started: 7:36:00 AM Error: 2013-11-20 07:36:04.36 Code: 0x00000000 Source: Set FSFileParameters Script Task My File Task Description: Access to the path '\\MyServer\E$\MyFiles\FSP\' is denied. End Error DTExec: The package execution returned DTSER_FAILURE (1). Started: 7:36:00 AM Finished: 7:36:04 AM Elapsed: 3.588 seconds. The package execution failed. The step failed.


    Forum User
    Post #1516003
    Posted Wednesday, November 20, 2013 6:23 AM


    SSCertifiable

    SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

    Group: General Forum Members
    Last Login: Monday, September 15, 2014 7:23 AM
    Points: 5,074, Visits: 11,852
    Try using a UNC path rather than a mapped drive.


    Help us to help you. For better, quicker and more-focused answers to your questions, consider following the advice in this link.

    When you ask a question (and please do ask a question: "My T-SQL does not work" just doesn't cut it), please provide enough information for us to understand its context.
    Post #1516014
    Posted Thursday, November 21, 2013 6:11 AM
    SSC Rookie

    SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

    Group: General Forum Members
    Last Login: Friday, July 4, 2014 12:04 PM
    Points: 33, Visits: 113
    I am using a UNC path, not a mapped drive.

    Forum User
    Post #1516393
    « Prev Topic | Next Topic »

    Add to briefcase ««123»»

    Permissions Expand / Collapse