Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Silent Install Of 2 SSRS Instances With Same Service Account Expand / Collapse
Author
Message
Posted Wednesday, October 9, 2013 8:00 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, October 30, 2013 1:51 PM
Points: 3, Visits: 38
Hello All

I am working on doing an automated silent install of SSRS and SQL Server. The silent install is meant to be generic so it can be quickly deployed so I use built in Accounts. So for Report Server I used RSSVCACCOUNT="NT Service\ReportServer" and for AGTSVCACCOUNT="NT Service\SQLSERVERAGENT". I know its not best practice but the goal is to get it installed automatically.

In my testing I am using silent install using Config File. For the initial install it installs fine. When I try to do a second install(instance 2) it doesn't work. For the 2nd install the only thing I am changing is INSTANCE NAME and INSTANCE ID. I am seeing errors related to invalid accounts even though they are the same accounts that work for the first install. One error for example I see is:

"The credentials you provided for the Reporting Services service are invalid. To continue, provide a valid account and password for the Reporting Services Service"

My question is I guess can you use the same service accounts for multiple instances? Any other ideas why this would fail when you use the same config file but change only the instance details? Any help would be greatly appreciated.

Thanks in Advance
Post #1503119
Posted Thursday, October 10, 2013 8:34 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, August 4, 2014 10:29 AM
Points: 2,251, Visits: 585
I'd like to do the same thing, but have not had any luck either, I'll follow this thread along to see if anyone has an answer to this - good luck

Tom in Sacramento

For better, quicker answers on T-SQL questions, click on the following...
http://www.sqlservercentral.com/articles/Best+Practices/61537/
Post #1503624
Posted Thursday, October 10, 2013 9:05 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, October 30, 2013 1:51 PM
Points: 3, Visits: 38
The funny thing is If I do an install via SQL Install wizard I can add the 2nd instance no problem. The only thing I am changing is the instance name. I changed to instance name sql2 for silent and no luck but via wizard I use sql3 for instance name and it works fine. Seems it has something to with when the instance name is appended to the service account. I see the below in the logs for non working silent install. Im not sure why its asking for a password for 'NT Service\ReportServer'

(01) 2013-10-09 20:25:03 Slp: Sco: Attempting to format the virtual account name from service name 'ReportServer$SQL2'

(01) 2013-10-09 20:25:03 Slp: Sco: Attempting to validate credentials for user account 'NT Service\ReportServer' and service name 'ReportServer$SQL2'

(01) 2013-10-09 20:25:03 Slp: Sco: Attempting to determine if the account 'NT Service\ReportServer' is Virtual Account

(01) 2013-10-09 20:25:03 RS: The credentials you provided for the Reporting Services service are invalid. To continue, provide a valid account and password for the Reporting Services service.

(01) 2013-10-09 20:25:03 RS: Microsoft.SqlServer.Configuration.Sco.InvalidVAException: Virtual Account 'NT Service\ReportServer' provided for 'ReportServer$SQL2' is either not a valid account or cannot be used for this service.

at Microsoft.SqlServer.Configuration.RSExtension.SQLRSConfigurationPublic.IsValidServiceAccount(ServiceContainer context, String userName, SqlSecureString password)

(01) 2013-10-09 20:25:03 Slp: Validation for setting 'AGTSVCACCOUNT' failed. Error message: Virtual Account 'NT Service\SQLSERVERAGENT' provided for 'SQLAgent$SQL2' is either not a valid account or cannot be used for this service.

(01) 2013-10-09 20:25:03 Slp: Validation for setting 'SQLSVCACCOUNT' failed. Error message: The SQL Server service account login or password is not valid. Use SQL Server Configuration Manager to update the service account.

(01) 2013-10-09 20:25:03 Slp: Validation for setting 'RSSVCAccount' failed. Error message: The credentials you provided for the Reporting Services service are invalid. To continue, provide a valid account and password for the Reporting Services service.

(01) 2013-10-09 20:25:03 Slp: Error: Action "Microsoft.SqlServer.Configuration.SetupExtension.ValidateFeatureSettingsAction" threw an exception during execution.
Post #1503640
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse