Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Transact log shipping not working Expand / Collapse
Author
Message
Posted Wednesday, September 11, 2013 2:03 PM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Friday, May 9, 2014 11:26 AM
Points: 54, Visits: 109
I am able to create and successfully run the 1st transact log shipping wizard and it finsihes and creates the database on 2nd server and creates all the job, but this is where It ends. the main server still does it thing backing up the logs and putting htem in the share drive, but the second server is not able to run its jobs for copying and backing up becuae I start getting this error on the system.

Login failed for user 'svc.?????.ngmn'. Reason: Token-based server access validation failed with an infrastructure error. Check for previous errors


I have searched alot on this but can't find anything to do with Transact logg shipping and sql jobs. Please Help.
Post #1493892
Posted Thursday, September 12, 2013 12:19 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Tuesday, September 23, 2014 2:53 AM
Points: 1,101, Visits: 5,290
What does the copy/restore job histary say?

Does the SQL Agent service account has read permission to the share?
Post #1494008
Posted Thursday, September 12, 2013 4:50 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Today @ 1:51 AM
Points: 141, Visits: 497
From memory (which is normally wrong) I think that error is related to Kerberos/Delegation.

Dan
Post #1494089
Posted Thursday, September 19, 2013 6:54 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Today @ 8:52 AM
Points: 113, Visits: 392
create a service account if you have already one, then go to the backup folder (in primary) and copy (secondary) and right click it and go to property and give permission to the service account.
This should work. if not post it here again.
Post #1496371
Posted Thursday, September 19, 2013 7:48 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Friday, May 9, 2014 11:26 AM
Points: 54, Visits: 109
i got it figured out it was a issue of the account not having access on the share, NTFS persmissions where not enough I had to give them access to the share.
Post #1496399
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse